Rhino C++ API
8.13
|
#include <RhRdkCurveGraph.h>
Public Member Functions | |
CRhRdkCurveGraphEvaluator (const wchar_t *wszXML) | |
virtual | ~CRhRdkCurveGraphEvaluator () |
virtual int | CurveCount (void) const |
virtual void * | EVF (const wchar_t *wszFunc, void *pvData) |
virtual double | GetCurveY (int iCurveIndex, double dX) const |
Calculates the Y coordinate of a curve graph at any X coordinate.
CRhRdkCurveGraphEvaluator::CRhRdkCurveGraphEvaluator | ( | const wchar_t * | wszXML | ) |
|
virtual |
|
virtual |
|
virtual |
Emergency virtual function for future expansion.
|
virtual |
Calculates the Y coordinate of a curve at the given X coordinate.
iCurveIndex | is the curve index of one of the curves on the graph. |
dX | is the X value to get the Y value for. |