Rhino C++ API
8.13
|
#include <RhRdkSun.h>
Public Member Functions | |
CRhRdkSun () | |
CRhRdkSun (const CRhRdkSun &sun) | |
CRhRdkSun (const ON_Sun &sun) | |
virtual | ~CRhRdkSun () |
void | FromOnSun (const ON_Sun &sun) |
operator IRhRdkSun & (void) const | |
bool | operator!= (const CRhRdkSun &sun) const |
const CRhRdkSun & | operator= (const CRhRdkSun &sun) |
bool | operator== (const CRhRdkSun &sun) const |
void | SetXML (const wchar_t *wszXML) |
virtual IRhRdkSun & | Sun (void) const |
void | ToOnSun (ON_Sun &sunOut) const |
ON_wString | XML (void) const |
Public Member Functions inherited from CRhRdkObject | |
CRhRdkObject () | |
virtual | ~CRhRdkObject () |
virtual void * | EVF (const wchar_t *wszFunc, void *pvData) |
void | operator delete (void *buf) |
void | operator delete[] (void *buf) |
void * | operator new (size_t size) |
void * | operator new[] (size_t size) |
Static Public Member Functions | |
static RDK_DEPRECATED IRhRdkSun * | NewImpl () |
Static Public Member Functions inherited from CRhRdkObject | |
static void | CheckMemory (void) |
static void | PopulateDebuggingInfo (void) |
Friends | |
class | IRhRdkSun |
This class represents a 'sun'. It can be used as a temporary sun property storage object or as a way to get sun XML or a light that represents a sun. However, please note that this is NOT the document sun. To use it, create one on the stack. Call Sun() to get an interface to the sun. Call the interface's various set methods to configure the sun the way you want it. You can copy the document sun to it if you wish. You might then call XML() or Light() to get an ON_Light to use as a sun light.
CRhRdkSun::CRhRdkSun | ( | ) |
CRhRdkSun::CRhRdkSun | ( | const CRhRdkSun & | sun | ) |
CRhRdkSun::CRhRdkSun | ( | const ON_Sun & | sun | ) |
|
virtual |
void CRhRdkSun::FromOnSun | ( | const ON_Sun & | sun | ) |
|
static |
|
inline |
bool CRhRdkSun::operator!= | ( | const CRhRdkSun & | sun | ) | const |
bool CRhRdkSun::operator== | ( | const CRhRdkSun & | sun | ) | const |
void CRhRdkSun::SetXML | ( | const wchar_t * | wszXML | ) |
|
virtual |
void CRhRdkSun::ToOnSun | ( | ON_Sun & | sunOut | ) | const |
ON_wString CRhRdkSun::XML | ( | void | ) | const |
|
friend |