Rhino C++ API  8.6
Public Member Functions | List of all members
CRhRdkTextureArray Class Referencefinal

#include <RhRdkTexture.h>

Inheritance diagram for CRhRdkTextureArray:
ON_SimpleArray< const CRhRdkTexture * >

Public Member Functions

void PopulateFrom (const CRhRdkContentArray &a)
 
void SetFilename (IRhinoUiController &controller, const wchar_t *wszFilename, const wchar_t *wszChildSlot=nullptr)
 
- Public Member Functions inherited from ON_SimpleArray< const CRhRdkTexture * >
 ON_SimpleArray () ON_NOEXCEPT
 construction //////////////////////////////////////////////////////// More...
 
 ON_SimpleArray (const ON_SimpleArray< const CRhRdkTexture * > &)
 Copy constructor. More...
 
 ON_SimpleArray (size_t)
 size_t parameter = initial capacity More...
 
virtual ~ON_SimpleArray ()
 
void Append (const const CRhRdkTexture * &)
 
void Append (int, const const CRhRdkTexture * *)
 Append copy of an array T[count]. More...
 
const CRhRdkTexture * & AppendNew ()
 array operations //////////////////////////////////////////////////// More...
 
const CRhRdkTexture * * Array ()
 The Array() function return the. More...
 
const const CRhRdkTexture * * Array () const
 m_a pointer value. More...
 
const CRhRdkTexture * * At (int)
 At(index) returns nullptr if index < 0 or index >= count. More...
 
const const CRhRdkTexture * * At (int) const
 
const CRhRdkTexture * * At (ON__INT64)
 
const const CRhRdkTexture * * At (ON__INT64) const
 
const CRhRdkTexture * * At (ON__UINT64)
 
const const CRhRdkTexture * * At (ON__UINT64) const
 
const CRhRdkTexture * * At (unsigned int)
 
const const CRhRdkTexture * * At (unsigned int) const
 
int BinarySearch (const const CRhRdkTexture * *, int(*)(const const CRhRdkTexture * *, const const CRhRdkTexture * *)) const
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
int BinarySearch (const const CRhRdkTexture * *, int(*)(const const CRhRdkTexture * *, const const CRhRdkTexture * *), int) const
 
const const CRhRdkTexture * * BinarySearchPtr (const const CRhRdkTexture * *, int(*)(const const CRhRdkTexture * *, const const CRhRdkTexture * *)) const
 
const const CRhRdkTexture * * BinarySearchPtr (const const CRhRdkTexture * *, int(*)(const const CRhRdkTexture * *, const const CRhRdkTexture * *), int) const
 
int Capacity () const
 capacity of array More...
 
int Count () const
 query /////////////////////////////////////////////////////////////// More...
 
ON__UINT32 DataCRC (ON__UINT32 current_remainder) const
 
void Destroy ()
 onfree any memory and set count and capacity to zero More...
 
void EmergencyDestroy (void)
 emergency bailout /////////////////////////////////////////////////// More...
 
void Empty ()
 Sets count to 0, leaves capacity untouched. More...
 
const CRhRdkTexture * * First ()
 
const const CRhRdkTexture * * First () const
 returns nullptr if count = 0 More...
 
bool HeapSort (int(*)(const const CRhRdkTexture * *, const const CRhRdkTexture * *))
 
void Insert (int, const const CRhRdkTexture * &)
 
int InsertInSortedList (const const CRhRdkTexture * &, int(*)(const const CRhRdkTexture * *, const const CRhRdkTexture * *))
 
int InsertInSortedList (const const CRhRdkTexture * &, int(*)(const const CRhRdkTexture * *, const const CRhRdkTexture * *), int)
 
const CRhRdkTexture * * KeepArray ()
 
const CRhRdkTexture * * Last ()
 
const const CRhRdkTexture * * Last () const
 returns nullptr if count = 0 More...
 
void MemSet (unsigned char)
 
int NewCapacity () const
 
 operator const const CRhRdkTexture * * () const
 
 operator const CRhRdkTexture ** ()
 The cast operators return a pointer. More...
 
ON_SimpleArray< const CRhRdkTexture * > & operator= (const ON_SimpleArray< const CRhRdkTexture * > &)
 
const CRhRdkTexture * & operator[] (int)
 
const const CRhRdkTexture * & operator[] (int) const
 
const CRhRdkTexture * & operator[] (ON__INT64)
 
const const CRhRdkTexture * & operator[] (ON__INT64) const
 
const CRhRdkTexture * & operator[] (ON__UINT64)
 
const const CRhRdkTexture * & operator[] (ON__UINT64) const
 
const CRhRdkTexture * & operator[] (unsigned int)
 
const const CRhRdkTexture * & operator[] (unsigned int) const
 
bool Permute (const int *)
 
void Prepend (int, const const CRhRdkTexture * *)
 Prepend copy of an array T[count]. More...
 
bool QuickSort (int(*)(const const CRhRdkTexture * *, const const CRhRdkTexture * *))
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
bool QuickSortAndRemoveDuplicates (int(*)(const const CRhRdkTexture * *, const const CRhRdkTexture * *))
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
virtual const CRhRdkTexture * * Realloc (const CRhRdkTexture * *, int)
 low level memory management ////////////////////////////////////////// More...
 
void Remove ()
 
virtual void Remove (int)
 
void RemoveIf (bool predicate(const const CRhRdkTexture * &key))
 
void RemoveValue (const const CRhRdkTexture * &)
 
const CRhRdkTexture * * Reserve (size_t)
 memory management //////////////////////////////////////////////////// More...
 
void Reverse ()
 reverse order More...
 
int Search (const const CRhRdkTexture * &) const
 
int Search (const const CRhRdkTexture * *, int(*)(const const CRhRdkTexture * *, const const CRhRdkTexture * *)) const
 See Also: ON_CompareIncreasing<T> and ON_CompareDeccreasing<T> More...
 
void SetArray (const CRhRdkTexture * *)
 
void SetArray (const CRhRdkTexture * *, int, int)
 
const CRhRdkTexture * * SetCapacity (size_t)
 
void SetCount (int)
 low level memory management ////////////////////////////////////////// More...
 
void SetRange (int from, int count, const CRhRdkTexture *)
 
void Shrink ()
 remove unused capacity More...
 
unsigned int SizeOfArray () const
 amount of memory in the m_a[] array More...
 
unsigned int SizeOfElement () const
 amount of memory in an m_a[] array element More...
 
bool Sort (ON::sort_algorithm sort_algorithm, int *, int(*)(const const CRhRdkTexture * *, const const CRhRdkTexture * *)) const
 
bool Sort (ON::sort_algorithm sort_algorithm, int *, int(*)(const const CRhRdkTexture * *, const const CRhRdkTexture * *, void *), void *) const
 
void Swap (int, int)
 swap elements i and j More...
 
unsigned int UnsignedCount () const
 
void Zero ()
 

Additional Inherited Members

- Protected Member Functions inherited from ON_SimpleArray< const CRhRdkTexture * >
void Move (int, int, int)
 implementation ////////////////////////////////////////////////////// More...
 
- Protected Attributes inherited from ON_SimpleArray< const CRhRdkTexture * >
const CRhRdkTexture * * m_a
 pointer to array memory More...
 
int m_capacity
 actual length of m_a[] More...
 
int m_count
 0 <= m_count <= m_capacity More...
 

Member Function Documentation

◆ PopulateFrom()

void CRhRdkTextureArray::PopulateFrom ( const CRhRdkContentArray a)

Populate this texture array from all textures in a content array.

◆ SetFilename()

void CRhRdkTextureArray::SetFilename ( IRhinoUiController controller,
const wchar_t *  wszFilename,
const wchar_t *  wszChildSlot = nullptr 
)

Call this method to update all of the textures with a new filename for file based textures.

Parameters
wszFilenameis the new filename.
wszChildSlotis the child slot name of the filename field. "filename" is used if nullptr is passed.