Rhino C++ API
8.13
|
#include <RhRdkDataSource.h>
Public Types | |
enum | EventPriority : unsigned int { EventPriority::Low, EventPriority::Normal, EventPriority::High, EventPriority::RealTime } |
Event priority More... | |
Public Member Functions | |
virtual void | Activate (void)=0 |
virtual UUID | Id (void) const =0 |
virtual bool | IsActivated (void) const =0 |
virtual void | RegisterEventWatcher (class IRhinoUiControllerEventWatcher &ew)=0 |
virtual void | RequiredDataSources (OUT ON_SimpleArray< ON_UUID > &aId) const =0 |
virtual EventPriority | SetEventPriority (EventPriority ep)=0 |
virtual void | UnregisterEventWatcher (class IRhinoUiControllerEventWatcher &ew)=0 |
Public Member Functions inherited from IRhinoUiDataSourceHost | |
virtual void | AddDataSource (class IRhinoUiDataSource &ds)=0 |
virtual void | Commit (const UUID &uuidData, IRhinoUiEventInfo *pInfo=nullptr)=0 |
virtual void | CopyDataSourcesFrom (IRhinoUiDataSourceHost &host)=0 |
virtual void | Discard (const UUID &uuidData)=0 |
virtual void * | GetData (const UUID &uuidData, bool bForWrite, bool bAutoChangeBracket=true) const =0 |
virtual void | GetDataSources (ON_SimpleArray< IRhinoUiDataSource * > &aOut) const =0 |
virtual void | RemoveDataSource (IRhinoUiDataSource &ds)=0 |
Public Member Functions inherited from IRhinoUiDataSourceEventWatcher | |
virtual void | Delete (void)=0 |
virtual void * | EVF (const wchar_t *wszFunc, void *pvData)=0 |
virtual void | OnEvent (const UUID &uuidData, const IRhinoUiEventInfo *pInfo)=0 |
Static Public Member Functions | |
static void | CustomDeleter (IRhinoUiController *) |
static std::shared_ptr< IRhinoUiController > | make_shared (IRhinoUiController *) |
Protected Member Functions | |
virtual | ~IRhinoUiController () |
Protected Member Functions inherited from IRhinoUiDataSourceEventWatcher | |
virtual | ~IRhinoUiDataSourceEventWatcher () |
|
strong |
|
inlineprotectedvirtual |
|
pure virtual |
Call this method when UI construction is complete and the values should be passed for the first time from the model to the view.
|
static |
|
pure virtual |
|
pure virtual |
|
static |
|
pure virtual |
Register an event watcher to be notified when the model changes.
|
pure virtual |
Retrieve an array of data source ids required by this controller.
|
pure virtual |
Set the event priority. You should only change the event priority around an event send and set it back to the old value afterwards.
|
pure virtual |
Unregister an event watcher which has been added by RegisterEventWatcher(). This must be done when the event watcher is deleted.