Rhino C++ API
8.13
|
#include <RhRdkDocument.h>
Public Member Functions | |
CRhRdkUndoableEvent (const CRhRdkDocument *pRdkDoc, const wchar_t *wszDesc) | |
CRhRdkUndoableEvent (CRhinoDoc &doc, const wchar_t *wszDesc) | |
CRhRdkUndoableEvent (CRhinoDoc *pDoc, const wchar_t *wszDesc) | |
virtual | ~CRhRdkUndoableEvent () |
Public Member Functions inherited from CRhRdkObject | |
CRhRdkObject () | |
virtual | ~CRhRdkObject () |
virtual void * | EVF (const wchar_t *wszFunc, void *pvData) |
void | operator delete (void *buf) |
void | operator delete[] (void *buf) |
void * | operator new (size_t size) |
void * | operator new[] (size_t size) |
Additional Inherited Members | |
Static Public Member Functions inherited from CRhRdkObject | |
static void | CheckMemory (void) |
static void | PopulateDebuggingInfo (void) |
The original version of the undoable event was intended for use with a document. This was before the data source system which was supposed to abstract the document away. Since 3rd-party plug-ins cannot actually use the data source system, this might still be useful for them.
CRhRdkUndoableEvent::CRhRdkUndoableEvent | ( | CRhinoDoc & | doc, |
const wchar_t * | wszDesc | ||
) |
Construct using a Rhino document.
CRhRdkUndoableEvent::CRhRdkUndoableEvent | ( | CRhinoDoc * | pDoc, |
const wchar_t * | wszDesc | ||
) |
Construct using a Rhino document pointer. If the pointer is null, the class does nothing.
CRhRdkUndoableEvent::CRhRdkUndoableEvent | ( | const CRhRdkDocument * | pRdkDoc, |
const wchar_t * | wszDesc | ||
) |
Construct using an RDK document pointer. If the pointer is null, the class does nothing.
|
virtual |