Rhino C++ API
8.13
|
#include <RhRdkUuidCollection.h>
Public Member Functions | |
CRhRdkUuidCollection () | |
CRhRdkUuidCollection (const CRhRdkUuidCollection &c) | |
virtual | ~CRhRdkUuidCollection () |
virtual void | Add (const UUID &uuid) |
virtual void | Clear (void) |
virtual bool | Contains (const UUID &uuid) const |
virtual int | Count (void) const |
virtual void | DebugDump (void) |
virtual ON_wString | GetSemicolonDelimitedString (void) const |
virtual bool | IsEmpty (void) const |
virtual bool | Next (UUID &uuidOut) const |
const CRhRdkUuidCollection & | operator= (const CRhRdkUuidCollection &c) |
virtual void | Remove (const UUID &uuid) |
virtual void | ResetIterator (void) |
virtual bool | SetSemicolonDelimitedString (const ON_wString &sUuidList) |
Public Member Functions inherited from CRhRdkObject | |
CRhRdkObject () | |
virtual | ~CRhRdkObject () |
virtual void * | EVF (const wchar_t *wszFunc, void *pvData) |
void | operator delete (void *buf) |
void | operator delete[] (void *buf) |
void * | operator new (size_t size) |
void * | operator new[] (size_t size) |
Additional Inherited Members | |
Static Public Member Functions inherited from CRhRdkObject | |
static void | CheckMemory (void) |
static void | PopulateDebuggingInfo (void) |
This class provides a collection of UUIDs. It can be used for collecting Rhino objects, Render Contents or anything else that is identified by a UUID.
CRhRdkUuidCollection::CRhRdkUuidCollection | ( | ) |
CRhRdkUuidCollection::CRhRdkUuidCollection | ( | const CRhRdkUuidCollection & | c | ) |
|
virtual |
|
virtual |
Add a UUID to the collection.
|
virtual |
Clear the collection.
|
virtual |
|
virtual |
|
virtual |
|
virtual |
Get the collection as a semicolon-delimited string of UUIDs.
|
virtual |
|
virtual |
Get the next UUID from the collection.
const CRhRdkUuidCollection& CRhRdkUuidCollection::operator= | ( | const CRhRdkUuidCollection & | c | ) |
Copy the collection.
|
virtual |
Remove a UUID from the collection.
|
virtual |
Reset the iterator for use with Next().
|
virtual |
Build the collection from a semicolon-delimited string of UUIDs.