#include <rhinoSdkDocProperties.h>
◆ CRhinoAnnotationSettingsEx()
CRhinoAnnotationSettingsEx::CRhinoAnnotationSettingsEx |
( |
| ) |
|
◆ ~CRhinoAnnotationSettingsEx()
CRhinoAnnotationSettingsEx::~CRhinoAnnotationSettingsEx |
( |
| ) |
|
◆ EnableHatchScaling()
void CRhinoAnnotationSettingsEx::EnableHatchScaling |
( |
bool |
bEnable | ) |
|
Description: Enables or disables hatch scaling.
◆ EnableLayoutSpaceAnnotationScaling()
void CRhinoAnnotationSettingsEx::EnableLayoutSpaceAnnotationScaling |
( |
bool |
bEnable | ) |
|
Description: Enables or disabled layout space annotation scaling.
◆ EnableModelSpaceAnnotationScaling()
void CRhinoAnnotationSettingsEx::EnableModelSpaceAnnotationScaling |
( |
bool |
bEnable | ) |
|
Description: Enables or disabled model space annotation scaling.
◆ IsHatchScalingEnabled()
bool CRhinoAnnotationSettingsEx::IsHatchScalingEnabled |
( |
| ) |
const |
Description: Return true if hatch scaling is enabled.
◆ IsLayoutSpaceAnnotationScalingEnabled()
bool CRhinoAnnotationSettingsEx::IsLayoutSpaceAnnotationScalingEnabled |
( |
| ) |
const |
Description: Return true if layout space annotation scaling is enabled.
◆ IsModelSpaceAnnotationScalingEnabled()
bool CRhinoAnnotationSettingsEx::IsModelSpaceAnnotationScalingEnabled |
( |
| ) |
const |
Description: Returns true if model space annotation scaling is enabled.
◆ ModelSpaceHatchScale()
double CRhinoAnnotationSettingsEx::ModelSpaceHatchScale |
( |
| ) |
const |
Description: Gets the scale factor for hatches in model space when hatch scaling is enabled.
◆ ModelSpaceTextScale()
double CRhinoAnnotationSettingsEx::ModelSpaceTextScale |
( |
| ) |
const |
Description: Gets the scale factor for text in model space when annotation scaling is enabled.
◆ SetModelSpaceHatchScale()
void CRhinoAnnotationSettingsEx::SetModelSpaceHatchScale |
( |
double |
scale | ) |
|
Description: Sets the scale factor for hatches in model space when hatch scaling is enabled.
◆ SetModelSpaceTextScale()
void CRhinoAnnotationSettingsEx::SetModelSpaceTextScale |
( |
double |
scale | ) |
|
Description: Sets the scale factor for text in model space when annotation scaling is enabled.