Rhino C++ API  8.6
Public Types | Public Member Functions | Public Attributes | Static Public Attributes | Friends | List of all members
CRhinoAppAppearanceSettings Class Reference

#include <rhinoSdkAppSettings.h>

Public Types

enum  command_prompt_position { command_prompt_top, command_prompt_bottom, command_prompt_floating, command_prompt_hidden }
 

Public Member Functions

 CRhinoAppAppearanceSettings ()
 
 CRhinoAppAppearanceSettings (const CRhinoAppAppearanceSettings &)
 
 ~CRhinoAppAppearanceSettings ()
 
void Defaults ()
 
ON_Color DirectionArrowIconColorU () const
 
ON_Color DirectionArrowIconColorV () const
 
ON_Color DirectionArrowIconColorW () const
 
int DirectionArrowIconThickness () const
 
void GetDefaultFontFaceName (ON_wString &font) const
 
void LoadProfile (CRhinoProfileContext &pc, unsigned int nDefaultLanguage=0)
 
ON_Color LockedObjectColor (bool isReferenceObject=false) const
 
bool operator!= (const CRhinoAppAppearanceSettings &src) const
 
CRhinoAppAppearanceSettingsoperator= (const CRhinoAppAppearanceSettings &)
 
bool operator== (const CRhinoAppAppearanceSettings &src) const
 
void SaveProfile (CRhinoProfileContext &) const
 
ON_Color SelectedObjectColor (bool isReferenceObject=false) const
 
ON_Color SelectionWindowCrossingFillColor () const
 
ON_Color SelectionWindowCrossingStrokeColor () const
 
ON_Color SelectionWindowFillColor () const
 
ON_Color SelectionWindowStrokeColor () const
 
void SetDirectionArrowIconColorU (const ON_Color &color)
 
void SetDirectionArrowIconColorV (const ON_Color &color)
 
void SetDirectionArrowIconColorW (const ON_Color &color)
 
void SetDirectionArrowIconThickness (int thickness)
 
void SetLockedObjectColor (ON_Color)
 
void SetSelectedObjectColor (ON_Color)
 
void SetSelectionWindowCrossingFillColor (const ON_Color &c)
 
void SetSelectionWindowCrossingStrokeColor (const ON_Color &c)
 
void SetSelectionWindowFillColor (const ON_Color &c)
 
void SetSelectionWindowStrokeColor (const ON_Color &c)
 
void SetShowExternalPdfPrinters (bool show)
 
void SetShowLayoutDropShadow (bool show)
 
void SetViewportTabsVisibleAtStart (bool on)
 
bool ShowExternalPdfPrinters () const
 Display PDF printers in the print dialog that are not the PDF driver built into Rhino. More...
 
bool ShowLayoutDropShadow () const
 Display drop shadow on layout viewports. More...
 
void SynchWithGUI ()
 
void ValidateFontSetting ()
 
bool ViewportTabsVisibleAtStart () const
 

Public Attributes

ON_Color m_cmdprompt_active_hypertext_color
 
ON_Color m_cmdprompt_background_color
 
int m_cmdprompt_font_height
 
ON_wString m_cmdprompt_font_name
 
int m_cmdprompt_height_in_lines
 
command_prompt_position m_cmdprompt_position
 
ON_Color m_cmdprompt_text_color
 command prompt window colors More...
 
ON_Color m_crosshair_color
 cross hair line color More...
 
ON_Color m_current_layer_bkcolor
 
ON_Color m_default_color
 
ON_Color m_default_layer_color
 default layer color More...
 
int m_direction_arrow_icon_head_size
 length of direction arrowhead icon in pixels More...
 
int m_direction_arrow_icon_shaft_size
 size of arrow icon used to indicate direction More...
 
bool m_echo_commands_to_history
 
bool m_echo_prompts_to_history
 
ON_Color m_edit_candidate_color
 Color of objects that are eligible to be edited. More...
 
ON_Color m_feedback_color
 
ON_Color m_frame_background_color
 frame window color attributes More...
 
unsigned int m_language_identifier
 
bool m_main_window_title
 main frame window title More...
 
ON_Color m_pageview_paper_color
 
bool m_show_crosshairs
 Cross hair color and state. More...
 
bool m_show_full_path_in_title_bar
 
bool m_show_menu
 
bool m_show_osnap_dialog
 display persistent Osnaps dialog More...
 
bool m_show_side_bar
 
bool m_show_statusbar
 
bool m_show_viewport_title
 TODO: should these be included? Used in V 2.0. More...
 
int m_statusbar_info_pane_mode
 
ON_Color m_tracking_color
 object creation and modification colors More...
 
ON_Color m_viewport_background_color
 view colors More...
 
int m_world_coord_icon_axis_size
 length of world coordinate sprite axis in pixels More...
 
bool m_world_coord_icon_bMoveLabels
 true to move axis letters as sprite rotates More...
 
int m_world_coord_icon_label_size
 "radius" of letter in pixels More...
 
ON_Color m_world_coord_icon_xaxis_color
 world coordinate sprite axes attributes More...
 
ON_Color m_world_coord_icon_yaxis_color
 
ON_Color m_world_coord_icon_zaxis_color
 

Static Public Attributes

static const CRhinoAppAppearanceSettings Default
 

Friends

class CRhDefaultColors
 

Detailed Description


Member Enumeration Documentation

◆ command_prompt_position

Enumerator
command_prompt_top 
command_prompt_bottom 
command_prompt_floating 
command_prompt_hidden 

Constructor & Destructor Documentation

◆ CRhinoAppAppearanceSettings() [1/2]

CRhinoAppAppearanceSettings::CRhinoAppAppearanceSettings ( )

◆ CRhinoAppAppearanceSettings() [2/2]

CRhinoAppAppearanceSettings::CRhinoAppAppearanceSettings ( const CRhinoAppAppearanceSettings )

◆ ~CRhinoAppAppearanceSettings()

CRhinoAppAppearanceSettings::~CRhinoAppAppearanceSettings ( )

Member Function Documentation

◆ Defaults()

void CRhinoAppAppearanceSettings::Defaults ( )

◆ DirectionArrowIconColorU()

ON_Color CRhinoAppAppearanceSettings::DirectionArrowIconColorU ( ) const

◆ DirectionArrowIconColorV()

ON_Color CRhinoAppAppearanceSettings::DirectionArrowIconColorV ( ) const

◆ DirectionArrowIconColorW()

ON_Color CRhinoAppAppearanceSettings::DirectionArrowIconColorW ( ) const

◆ DirectionArrowIconThickness()

int CRhinoAppAppearanceSettings::DirectionArrowIconThickness ( ) const

◆ GetDefaultFontFaceName()

void CRhinoAppAppearanceSettings::GetDefaultFontFaceName ( ON_wString font) const

◆ LoadProfile()

void CRhinoAppAppearanceSettings::LoadProfile ( CRhinoProfileContext pc,
unsigned int  nDefaultLanguage = 0 
)

◆ LockedObjectColor()

ON_Color CRhinoAppAppearanceSettings::LockedObjectColor ( bool  isReferenceObject = false) const

Description: Get the color used to draw selected objects (default is yellow) Parameters: bIsReferenceObject - [in] if true, the color used for selected reference model objects is returned.

◆ operator!=()

bool CRhinoAppAppearanceSettings::operator!= ( const CRhinoAppAppearanceSettings src) const

◆ operator=()

CRhinoAppAppearanceSettings& CRhinoAppAppearanceSettings::operator= ( const CRhinoAppAppearanceSettings )

◆ operator==()

bool CRhinoAppAppearanceSettings::operator== ( const CRhinoAppAppearanceSettings src) const

◆ SaveProfile()

void CRhinoAppAppearanceSettings::SaveProfile ( CRhinoProfileContext ) const

◆ SelectedObjectColor()

ON_Color CRhinoAppAppearanceSettings::SelectedObjectColor ( bool  isReferenceObject = false) const

Description: Get the color used to draw selected objects (default is yellow) Parameters: bIsReferenceObject - [in] if true, the color used for selected reference model objects is returned.

◆ SelectionWindowCrossingFillColor()

ON_Color CRhinoAppAppearanceSettings::SelectionWindowCrossingFillColor ( ) const

◆ SelectionWindowCrossingStrokeColor()

ON_Color CRhinoAppAppearanceSettings::SelectionWindowCrossingStrokeColor ( ) const

◆ SelectionWindowFillColor()

ON_Color CRhinoAppAppearanceSettings::SelectionWindowFillColor ( ) const

◆ SelectionWindowStrokeColor()

ON_Color CRhinoAppAppearanceSettings::SelectionWindowStrokeColor ( ) const

◆ SetDirectionArrowIconColorU()

void CRhinoAppAppearanceSettings::SetDirectionArrowIconColorU ( const ON_Color color)

◆ SetDirectionArrowIconColorV()

void CRhinoAppAppearanceSettings::SetDirectionArrowIconColorV ( const ON_Color color)

◆ SetDirectionArrowIconColorW()

void CRhinoAppAppearanceSettings::SetDirectionArrowIconColorW ( const ON_Color color)

◆ SetDirectionArrowIconThickness()

void CRhinoAppAppearanceSettings::SetDirectionArrowIconThickness ( int  thickness)

◆ SetLockedObjectColor()

void CRhinoAppAppearanceSettings::SetLockedObjectColor ( ON_Color  )

◆ SetSelectedObjectColor()

void CRhinoAppAppearanceSettings::SetSelectedObjectColor ( ON_Color  )

◆ SetSelectionWindowCrossingFillColor()

void CRhinoAppAppearanceSettings::SetSelectionWindowCrossingFillColor ( const ON_Color c)

◆ SetSelectionWindowCrossingStrokeColor()

void CRhinoAppAppearanceSettings::SetSelectionWindowCrossingStrokeColor ( const ON_Color c)

◆ SetSelectionWindowFillColor()

void CRhinoAppAppearanceSettings::SetSelectionWindowFillColor ( const ON_Color c)

◆ SetSelectionWindowStrokeColor()

void CRhinoAppAppearanceSettings::SetSelectionWindowStrokeColor ( const ON_Color c)

◆ SetShowExternalPdfPrinters()

void CRhinoAppAppearanceSettings::SetShowExternalPdfPrinters ( bool  show)

◆ SetShowLayoutDropShadow()

void CRhinoAppAppearanceSettings::SetShowLayoutDropShadow ( bool  show)

◆ SetViewportTabsVisibleAtStart()

void CRhinoAppAppearanceSettings::SetViewportTabsVisibleAtStart ( bool  on)

◆ ShowExternalPdfPrinters()

bool CRhinoAppAppearanceSettings::ShowExternalPdfPrinters ( ) const

Display PDF printers in the print dialog that are not the PDF driver built into Rhino.

◆ ShowLayoutDropShadow()

bool CRhinoAppAppearanceSettings::ShowLayoutDropShadow ( ) const

Display drop shadow on layout viewports.

◆ SynchWithGUI()

void CRhinoAppAppearanceSettings::SynchWithGUI ( )

◆ ValidateFontSetting()

void CRhinoAppAppearanceSettings::ValidateFontSetting ( )

Description: Makes sure the font is appropriate for the locale that is selected.

◆ ViewportTabsVisibleAtStart()

bool CRhinoAppAppearanceSettings::ViewportTabsVisibleAtStart ( ) const

Friends And Related Function Documentation

◆ CRhDefaultColors

friend class CRhDefaultColors
friend

Member Data Documentation

◆ Default

const CRhinoAppAppearanceSettings CRhinoAppAppearanceSettings::Default
static

◆ m_cmdprompt_active_hypertext_color

ON_Color CRhinoAppAppearanceSettings::m_cmdprompt_active_hypertext_color

◆ m_cmdprompt_background_color

ON_Color CRhinoAppAppearanceSettings::m_cmdprompt_background_color

◆ m_cmdprompt_font_height

int CRhinoAppAppearanceSettings::m_cmdprompt_font_height

◆ m_cmdprompt_font_name

ON_wString CRhinoAppAppearanceSettings::m_cmdprompt_font_name

◆ m_cmdprompt_height_in_lines

int CRhinoAppAppearanceSettings::m_cmdprompt_height_in_lines
Deprecated:
no longer used

◆ m_cmdprompt_position

command_prompt_position CRhinoAppAppearanceSettings::m_cmdprompt_position
Deprecated:
no longer used

◆ m_cmdprompt_text_color

ON_Color CRhinoAppAppearanceSettings::m_cmdprompt_text_color

command prompt window colors

◆ m_crosshair_color

ON_Color CRhinoAppAppearanceSettings::m_crosshair_color

cross hair line color

◆ m_current_layer_bkcolor

ON_Color CRhinoAppAppearanceSettings::m_current_layer_bkcolor

This color is used by the layer manager dialog as the background color for the current layer.

◆ m_default_color

ON_Color CRhinoAppAppearanceSettings::m_default_color

default object color

◆ m_default_layer_color

ON_Color CRhinoAppAppearanceSettings::m_default_layer_color

default layer color

◆ m_direction_arrow_icon_head_size

int CRhinoAppAppearanceSettings::m_direction_arrow_icon_head_size

length of direction arrowhead icon in pixels

◆ m_direction_arrow_icon_shaft_size

int CRhinoAppAppearanceSettings::m_direction_arrow_icon_shaft_size

size of arrow icon used to indicate direction

length of direction arrow shaft icon in pixels

◆ m_echo_commands_to_history

bool CRhinoAppAppearanceSettings::m_echo_commands_to_history

◆ m_echo_prompts_to_history

bool CRhinoAppAppearanceSettings::m_echo_prompts_to_history

◆ m_edit_candidate_color

ON_Color CRhinoAppAppearanceSettings::m_edit_candidate_color

Color of objects that are eligible to be edited.

◆ m_feedback_color

ON_Color CRhinoAppAppearanceSettings::m_feedback_color

◆ m_frame_background_color

ON_Color CRhinoAppAppearanceSettings::m_frame_background_color

frame window color attributes

◆ m_language_identifier

unsigned int CRhinoAppAppearanceSettings::m_language_identifier

◆ m_main_window_title

bool CRhinoAppAppearanceSettings::m_main_window_title

main frame window title

◆ m_pageview_paper_color

ON_Color CRhinoAppAppearanceSettings::m_pageview_paper_color

CRhinoPageView paper background. A rectangle is drawn into the background of page views to represent the printed area. The alpha portion of the color is used to draw the paper blended into the background

◆ m_show_crosshairs

bool CRhinoAppAppearanceSettings::m_show_crosshairs

Cross hair color and state.

lines that extend across the view

◆ m_show_full_path_in_title_bar

bool CRhinoAppAppearanceSettings::m_show_full_path_in_title_bar

◆ m_show_menu

bool CRhinoAppAppearanceSettings::m_show_menu

◆ m_show_osnap_dialog

bool CRhinoAppAppearanceSettings::m_show_osnap_dialog

display persistent Osnaps dialog

◆ m_show_side_bar

bool CRhinoAppAppearanceSettings::m_show_side_bar

◆ m_show_statusbar

bool CRhinoAppAppearanceSettings::m_show_statusbar

◆ m_show_viewport_title

bool CRhinoAppAppearanceSettings::m_show_viewport_title

TODO: should these be included? Used in V 2.0.

viewport name in top left cornner

◆ m_statusbar_info_pane_mode

int CRhinoAppAppearanceSettings::m_statusbar_info_pane_mode

◆ m_tracking_color

ON_Color CRhinoAppAppearanceSettings::m_tracking_color

object creation and modification colors

◆ m_viewport_background_color

ON_Color CRhinoAppAppearanceSettings::m_viewport_background_color

view colors

◆ m_world_coord_icon_axis_size

int CRhinoAppAppearanceSettings::m_world_coord_icon_axis_size

length of world coordinate sprite axis in pixels

◆ m_world_coord_icon_bMoveLabels

bool CRhinoAppAppearanceSettings::m_world_coord_icon_bMoveLabels

true to move axis letters as sprite rotates

◆ m_world_coord_icon_label_size

int CRhinoAppAppearanceSettings::m_world_coord_icon_label_size

"radius" of letter in pixels

◆ m_world_coord_icon_xaxis_color

ON_Color CRhinoAppAppearanceSettings::m_world_coord_icon_xaxis_color

world coordinate sprite axes attributes

◆ m_world_coord_icon_yaxis_color

ON_Color CRhinoAppAppearanceSettings::m_world_coord_icon_yaxis_color

◆ m_world_coord_icon_zaxis_color

ON_Color CRhinoAppAppearanceSettings::m_world_coord_icon_zaxis_color