Rhino C++ API  8.6
Public Types | Public Member Functions | Public Attributes | List of all members
CRhinoCSXEvent Class Reference

#include <RhinoSdkIntersect.h>

Public Types

enum  EVENT_TYPE { CSX_NO_EVENT = 0, CSX_POINT = 1, CSX_OVERLAP = 2, CSX_EVENT_TYPE__FORCE__INT = 0xFFFFFFFF }
 

Public Member Functions

int Compare (const CRhinoCSXEvent &other) const
 

Public Attributes

ON_3dPoint m_A [2]
 intersection point(s) on curve More...
 
double m_a [2]
 intersection parameter(s) on curve More...
 
ON_3dPoint m_B [2]
 intersection point(s) on surface More...
 
ON_2dPoint m_b [2]
 intersection parameter(s) on surface More...
 
EVENT_TYPE m_type
 

Member Enumeration Documentation

◆ EVENT_TYPE

There are two valid curve-surface intersection events CSX_POINT - curves intersect in an isolated point a[0] = a[1] = curve parameter A[0] = A[1] = intersection point on curve b[0] = b[1] = surface parameter B[0] = B[1] = intersection point on surface

CSX_OVERLAP (a[0],a[1]) = curve parameter range A[0] = intersection start point on first curve A[1] = intersection end point on first curve b[0] = surface parameter for start point b[1] = surface parameter for end point B[0] = intersection start point on surface B[1] = intersection end point on surface

Enumerator
CSX_NO_EVENT 
CSX_POINT 

curve-surface intersection point

CSX_OVERLAP 

curve-surface intersection overlap

CSX_EVENT_TYPE__FORCE__INT 

Member Function Documentation

◆ Compare()

int CRhinoCSXEvent::Compare ( const CRhinoCSXEvent other) const

Description: Compare "this" intersection event with "other". Parameters: other - [in] Returns: @untitled table -1 this < other 0 this = other +1 this > other Remarks: Compare is used to sort intersection events into canonical order.

Member Data Documentation

◆ m_A

ON_3dPoint CRhinoCSXEvent::m_A[2]

intersection point(s) on curve

◆ m_a

double CRhinoCSXEvent::m_a[2]

intersection parameter(s) on curve

◆ m_B

ON_3dPoint CRhinoCSXEvent::m_B[2]

intersection point(s) on surface

◆ m_b

ON_2dPoint CRhinoCSXEvent::m_b[2]

intersection parameter(s) on surface

◆ m_type

EVENT_TYPE CRhinoCSXEvent::m_type