Rhino C++ API
8.13
|
#include <rhinoSdkDigitizerInfo.h>
Public Member Functions | |
CRhinoDigitizerInfo () | |
~CRhinoDigitizerInfo () | |
Public Attributes | |
bool | m_bIsActive |
true if GetPoint can accept digitizer input More... | |
bool | m_bIsCalibrated |
true if a digitizer is connected and calibrated More... | |
bool | m_bIsConnected |
true if a digitizer is connected More... | |
bool | m_bIsPaused |
true if a digitizer is connected and paused More... | |
ON_3dPoint | m_dig_origin |
ON_Xform | m_dig_point_xform |
transforms point (has unit system scaling) More... | |
double | m_dig_tol |
in m_dig_us units More... | |
ON::LengthUnitSystem | m_dig_us |
This information is from the current digitizer. More... | |
ON_Xform | m_dig_vector_xform |
transforms directions More... | |
ON_3dVector | m_dig_xaxis |
ON_3dVector | m_dig_yaxis |
ON_3dPoint | m_rhino_origin |
ON_3dVector | m_rhino_xaxis |
ON_3dVector | m_rhino_yaxis |
double | m_scale |
digitizer to rhino scale factor More... | |
double | m_user_scale |
This user defined scale factor is set by the "DigScale" command. More... | |
UUID | m_uuid |
uuid of the current digitizer More... | |
Copyright (c) 1993-2017 Robert McNeel & Associates. All rights reserved. Rhinoceros is a registered trademark of Robert McNeel & Associates.
THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT EXPRESS OR IMPLIED WARRANTY. ALL IMPLIED WARRANTIES OF FITNESS FOR ANY PARTICULAR PURPOSE AND OF MERCHANTABILITY ARE HEREBY DISCLAIMED.
For complete Rhino SDK copyright information see http://www.rhino3d.com/developer. Description: The CRhinoDigitizerInfo class holds the current state of the active 3D digitizing device. Also See: RhinoGetDigitizerInfo
CRhinoDigitizerInfo::CRhinoDigitizerInfo | ( | ) |
CRhinoDigitizerInfo::~CRhinoDigitizerInfo | ( | ) |
bool CRhinoDigitizerInfo::m_bIsActive |
true if GetPoint can accept digitizer input
bool CRhinoDigitizerInfo::m_bIsCalibrated |
true if a digitizer is connected and calibrated
bool CRhinoDigitizerInfo::m_bIsConnected |
true if a digitizer is connected
bool CRhinoDigitizerInfo::m_bIsPaused |
true if a digitizer is connected and paused
ON_3dPoint CRhinoDigitizerInfo::m_dig_origin |
These points are in digitizer coordinates and are set by the "DigCalibrate" command
ON_Xform CRhinoDigitizerInfo::m_dig_point_xform |
transforms point (has unit system scaling)
double CRhinoDigitizerInfo::m_dig_tol |
in m_dig_us units
ON::LengthUnitSystem CRhinoDigitizerInfo::m_dig_us |
This information is from the current digitizer.
ON_Xform CRhinoDigitizerInfo::m_dig_vector_xform |
transforms directions
ON_3dVector CRhinoDigitizerInfo::m_dig_xaxis |
ON_3dVector CRhinoDigitizerInfo::m_dig_yaxis |
ON_3dPoint CRhinoDigitizerInfo::m_rhino_origin |
These points are in rhino world coordinates and are set by the "DigCalibrate" command
ON_3dVector CRhinoDigitizerInfo::m_rhino_xaxis |
ON_3dVector CRhinoDigitizerInfo::m_rhino_yaxis |
double CRhinoDigitizerInfo::m_scale |
digitizer to rhino scale factor
double CRhinoDigitizerInfo::m_user_scale |
This user defined scale factor is set by the "DigScale" command.
UUID CRhinoDigitizerInfo::m_uuid |
uuid of the current digitizer