Rhino C++ API
8.18
Main Page
Related Pages
Modules
Classes
Class List
Class Index
Class Hierarchy
Class Members
All
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
~
Functions
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
~
Variables
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
Typedefs
Enumerations
a
b
c
d
e
f
g
h
i
k
l
m
n
o
p
q
r
s
t
u
v
w
Enumerator
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
Related Functions
c
d
g
i
o
q
r
s
t
•
All
Classes
Namespaces
Functions
Variables
Typedefs
Enumerations
Enumerator
Friends
Modules
Pages
CRhinoHistoryManager Member List
This is the complete list of members for
CRhinoHistoryManager
, including all inherited members.
BrokenRecordCount
()
CRhinoHistoryManager
BrokenRecordWarningEnabled
() const
CRhinoHistoryManager
CheckForBrokenRecords
(int action, unsigned int rhino_doc_sn, const CRhinoCommand *cmd)
CRhinoHistoryManager
CRhinoApp
class
CRhinoHistoryManager
friend
CRhinoDoc
class
CRhinoHistoryManager
friend
CRhinoHistoryManager
()
CRhinoHistoryManager
CRhinoInstanceDefinitionTable
class
CRhinoHistoryManager
friend
DeleteObjectHelper
(const CRhinoObject *old_object)
CRhinoHistoryManager
EnableBrokenRecordWarning
(bool bEnableBrokenRecordWarning)
CRhinoHistoryManager
EnableHistoryObjectLocking
(bool bEnableHistoryObjectLocking)
CRhinoHistoryManager
EnableHistoryRecording
(bool bEnableHistoryRecording)
CRhinoHistoryManager
EnableHistoryUpdate
(bool bEnableHistoryUpdate)
CRhinoHistoryManager
HistoryObjectLockingEnabled
() const
CRhinoHistoryManager
HistoryRecordingEnabled
() const
CRhinoHistoryManager
HistoryUpdateActive
() const
CRhinoHistoryManager
HistoryUpdateEnabled
() const
CRhinoHistoryManager
LoadProfile
(LPCTSTR lpszSection, CRhinoProfileContext &pc)
CRhinoHistoryManager
ModifyObjectAttributesHelper
(const CRhinoObject *object)
CRhinoHistoryManager
PopRecordSetting
()
CRhinoHistoryManager
PushRecordSetting
()
CRhinoHistoryManager
RecordNextCommand
() const
CRhinoHistoryManager
RecordSettingStackCount
() const
CRhinoHistoryManager
SaveProfile
(LPCTSTR lpszSection, CRhinoProfileContext &pc)
CRhinoHistoryManager
SetRecordNextCommand
(bool bRecordNextCommand)
CRhinoHistoryManager
UpdateDescendants
(class CRhinoDoc &doc)
CRhinoHistoryManager
ZeroBrokenRecordCounter
()
CRhinoHistoryManager
~CRhinoHistoryManager
()
CRhinoHistoryManager
Generated on Tue Apr 8 2025 16:23:50 for Rhino C++ API by
1.8.17