#include <rhinoSdkObjectHistory.h>
◆ CRhinoHistoryManager()
CRhinoHistoryManager::CRhinoHistoryManager |
( |
| ) |
|
TODO: Make these private when RhinoHistoryManager turns into CRhionApp:HistoryManager()
◆ ~CRhinoHistoryManager()
CRhinoHistoryManager::~CRhinoHistoryManager |
( |
| ) |
|
◆ BrokenRecordCount()
int CRhinoHistoryManager::BrokenRecordCount |
( |
| ) |
|
Description: These tools check for and alert users when history records are broken. Parameters action - [in] 0 command 1 object drag cmd - [in] (can be NULL) command
◆ BrokenRecordWarningEnabled()
bool CRhinoHistoryManager::BrokenRecordWarningEnabled |
( |
| ) |
const |
◆ CheckForBrokenRecords()
void CRhinoHistoryManager::CheckForBrokenRecords |
( |
int |
action, |
|
|
unsigned int |
rhino_doc_sn, |
|
|
const CRhinoCommand * |
cmd |
|
) |
| |
◆ DeleteObjectHelper()
bool CRhinoHistoryManager::DeleteObjectHelper |
( |
const CRhinoObject * |
old_object | ) |
|
Description: Called by Trim and Split when using replace object is not feasible.
◆ EnableBrokenRecordWarning()
void CRhinoHistoryManager::EnableBrokenRecordWarning |
( |
bool |
bEnableBrokenRecordWarning | ) |
|
◆ EnableHistoryObjectLocking()
void CRhinoHistoryManager::EnableHistoryObjectLocking |
( |
bool |
bEnableHistoryObjectLocking | ) |
|
Description: When history object locking is enabled, objects with history on them act as if they were locked and the only way to modify these objects is to edit their inputs. Parameters: bEnableHistoryObjectLocking - [in]
◆ EnableHistoryRecording()
void CRhinoHistoryManager::EnableHistoryRecording |
( |
bool |
bEnableHistoryRecording | ) |
|
Description: Sets switch for history recording.
If the master history recording switch is off, then no history is recorded. If the master history recording switch is on, the the command's history recording setting determines if a command records history. Parameters: bEnableHistoryRecording - [in]
◆ EnableHistoryUpdate()
void CRhinoHistoryManager::EnableHistoryUpdate |
( |
bool |
bEnableHistoryUpdate | ) |
|
Description: When history update is enabled, dependent objects are automatically updated when an antecedent is modified. Parameters: bEnableHistoryUpdate - [in] true to enable history update
◆ HistoryObjectLockingEnabled()
bool CRhinoHistoryManager::HistoryObjectLockingEnabled |
( |
| ) |
const |
Description: When history update is enabled, dependent objects are automatically updated when an antecedent is modified. Returns: true if history update is enabled.
◆ HistoryRecordingEnabled()
bool CRhinoHistoryManager::HistoryRecordingEnabled |
( |
| ) |
const |
Description: When history recording is enabled, new objects keep a record of how they were constructed so that they can be updated if an input object changes. Returns: The current history recording setting. If a command is running, the current setting is true only when the master switch is on and the command has recording enabled. Remarks: This reports the CURRENT APPLICATION setting.
In order for history to be recorded during a command, both the application setting and the command setting have to be true.
◆ HistoryUpdateActive()
bool CRhinoHistoryManager::HistoryUpdateActive |
( |
| ) |
const |
Description: Returns: true if the history manager is in the process of updating objects because their antecedents were modified.
◆ HistoryUpdateEnabled()
bool CRhinoHistoryManager::HistoryUpdateEnabled |
( |
| ) |
const |
Description: When history update is enabled, dependent objects are automatically updated when an antecedent is modified. Returns: true if history update is enabled.
◆ LoadProfile()
◆ ModifyObjectAttributesHelper()
bool CRhinoHistoryManager::ModifyObjectAttributesHelper |
( |
const CRhinoObject * |
object | ) |
|
◆ PopRecordSetting()
bool CRhinoHistoryManager::PopRecordSetting |
( |
| ) |
|
Description: Sets the current value of the record setting to the value on the stack. Returns: Value of the record setting after the pop.
◆ PushRecordSetting()
void CRhinoHistoryManager::PushRecordSetting |
( |
| ) |
|
Description: Puts a the current value of the record setting on a private stack.
◆ RecordNextCommand()
bool CRhinoHistoryManager::RecordNextCommand |
( |
| ) |
const |
◆ RecordSettingStackCount()
int CRhinoHistoryManager::RecordSettingStackCount |
( |
| ) |
const |
Returns: Number of values in the record setting stack.
◆ SaveProfile()
◆ SetRecordNextCommand()
void CRhinoHistoryManager::SetRecordNextCommand |
( |
bool |
bRecordNextCommand | ) |
|
◆ UpdateDescendants()
Expert user tools
- no support available
- can change without notice
◆ ZeroBrokenRecordCounter()
void CRhinoHistoryManager::ZeroBrokenRecordCounter |
( |
| ) |
|
◆ CRhinoApp
Note: No data members of this class are public. This class can be modified without breaking the SDK as long as existing public member functions are not changed.
◆ CRhinoDoc
◆ CRhinoInstanceDefinitionTable