Rhino C++ API  8.6
Public Member Functions | Public Attributes | List of all members
CRhinoMeshBooleanOptions Class Reference

Contains additional information about mesh booleans. This class can have more methods added. More...

#include <rhinoSdkMeshUtilities.h>

Public Member Functions

 CRhinoMeshBooleanOptions ()
 
 ~CRhinoMeshBooleanOptions ()
 
void RequestFirstNewlyAddedFacesList (ON_SimpleArray< unsigned > *list)
 Retuns a list with the first index, the first index of the first newly added mesh face, and as secondo index, the count of new faces after that index. More...
 

Public Attributes

ON_Terminatorm_cancel = nullptr
 
bool m_ngons = true
 
ON_ProgressReporterm_reporter = nullptr
 
ON_TextLogm_text_log = nullptr
 

Detailed Description

Contains additional information about mesh booleans. This class can have more methods added.

Constructor & Destructor Documentation

◆ ~CRhinoMeshBooleanOptions()

CRhinoMeshBooleanOptions::~CRhinoMeshBooleanOptions ( )

◆ CRhinoMeshBooleanOptions()

CRhinoMeshBooleanOptions::CRhinoMeshBooleanOptions ( )

Member Function Documentation

◆ RequestFirstNewlyAddedFacesList()

void CRhinoMeshBooleanOptions::RequestFirstNewlyAddedFacesList ( ON_SimpleArray< unsigned > *  list)

Retuns a list with the first index, the first index of the first newly added mesh face, and as secondo index, the count of new faces after that index.

Parameters
listThe indices of the new faces, as addessed in the summary.

Member Data Documentation

◆ m_cancel

ON_Terminator* CRhinoMeshBooleanOptions::m_cancel = nullptr

◆ m_ngons

bool CRhinoMeshBooleanOptions::m_ngons = true

◆ m_reporter

ON_ProgressReporter* CRhinoMeshBooleanOptions::m_reporter = nullptr

◆ m_text_log

ON_TextLog* CRhinoMeshBooleanOptions::m_text_log = nullptr