Rhino C++ API
8.13
|
#include <RhinoSdkRender.h>
Public Types | |
enum | RenderReturnCodes { render_ok = 0, render_empty_scene, render_cancel, render_no_active_view, render_on_pre_create_window, render_no_frame_wnd_pointer, render_error_creating_window, render_error_starting_render, render_enter_modal_loop, render_exit_modal_loop, render_wm_quit } |
Render command an helpers. More... | |
Protected Member Functions | |
CImpl * | Impl () |
RenderReturnCodes | ReturnRenderCode (RenderReturnCodes rc) |
CRhinoView * | RhinoView () const |
void | SetRhinoView (CRhinoView *v) |
Protected Attributes | |
friend | CImpl |
bool | m_batch_mode |
DWORD | m_end_time |
int | m_error_code |
int | m_light_count |
int | m_mesh_count |
CRhinoRenderPlugIn * | m_plugin |
BOOL32 | m_render_canceled |
CRhinoDoc & | m_rhino_doc |
CRhinoView * | m_rhino_view |
ON__UINT_PTR | m_sdk_reserved = 0 |
DWORD | m_start_time |
Friends | |
class | CRhinoSdkRenderEx |
Copyright (c) 1993-2017 Robert McNeel & Associates. All rights reserved. Rhinoceros is a registered trademark of Robert McNeel & Associates.
THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT EXPRESS OR IMPLIED WARRANTY. ALL IMPLIED WARRANTIES OF FITNESS FOR ANY PARTICULAR PURPOSE AND OF MERCHANTABILITY ARE HEREBY DISCLAIMED.
For complete Rhino SDK copyright information see http://www.rhino3d.com/developer. This class has been modified, you should now use the CRhinoSdkRenderEx class defined at the bottom of this file.
|
virtual |
|
virtual |
Description: Called br ProcessGeometryTable() when an light is encountered that should be included in the rendered scene. Returns: TRUE - If plug-in will use this light FALSE - ignore this light
|
virtual |
Description: Called br ProcessGeometryTable() when an object is encountered that contains a render mesh. Returns: TRUE - If plug-in will render this object FALSE - object won't be rendered
|
inline |
double CRhinoSdkRender::ElapsedTime | ( | ON_wString & | out | ) | const |
|
inline |
int CRhinoSdkRender::ErrorCode | ( | ) | const |
Description: Returns code which caused Render() or RenderWindow() to terminate. Returns: Returns code which caused Render() or RenderWindow() to terminate.
|
virtual |
Description: Called br ProcessGeometryTable() when an object is encountered that does not contain a render mesh. Returns: TRUE - object won't be rendered FALSE - If plug-in will render this object
|
protected |
bool CRhinoSdkRender::InBatchMode | ( | ) | const |
Description: Determines if -Render or -RenderWindow was started command. Returns: A value of true means we are in batch scripting mode.
|
virtual |
Virtual interface
Description: Called by Render() to determine if ProcessGeometryTable() will get called. Returns: TRUE - Render() will call ProcessGeometryTable() FALSE - nothing changed so use plug-ins own mesh list
|
virtual |
Description: Called by Render() to determine if ProcessLightTable() will get called. Returns: TRUE - Render() will call ProcessLightTable() FALSE - nothing changed so use plug-ins own light list
|
pure virtual |
Description: Called by Render() just after RenderPreCreateWindow(). The frame returned by this function will be used to display the rendered image in. Parameters: doc - [in] Active Rhino document; Returns: Pointer to CRhinoSdkRenderFrame object. If NULL is returned then Render() will abort.
Implemented in CRhinoSdkRenderEx2.
void CRhinoSdkRender::OnRenderFrameDestruction | ( | ) |
For internal use only.
|
virtual |
Description: If your renderer supports pause / resume, override this method to pause rendering.
CRhinoRenderPlugIn* CRhinoSdkRender::PlugIn | ( | ) | const |
int CRhinoSdkRender::ProcessGeometryTable | ( | ) |
int CRhinoSdkRender::ProcessLightTable | ( | ) |
RenderReturnCodes CRhinoSdkRender::Render | ( | const CRhinoCommandContext & | context, |
LPSIZE | sizeImage = 0 , |
||
const wchar_t * | lpsWindowTitle = 0 , |
||
UINT | nIDResource = 0 |
||
) |
|
virtual |
Description: Called by Render() and RenderWindow() during modal processing. Modal loop will continue until a cancel event occurs until this function returns false. Returns: If false when rendering is complete. This allows the Render and RenderWindow commands to return control to Rhino when rendering is complete.
|
virtual |
Description: Called by Render() and RenderWindow() just prior to entering modal loop. Returns: If false is returned Render() and RenderWindow() will abort.
|
virtual |
Description: Called by Render() and RenderWindow() just after modal loop is exited. Returns: If false is returned Render() and and RenderWindow() will cancel.
|
virtual |
Description: Called by Render() just prior to calling NewRenderFrame(). Called by RenderWindow() just prior to calling StartRenderingInWindow(); Returns: If false is returned then the Render() or RenderWindow() will abort.
void CRhinoSdkRender::RenderReturnCodesToString | ( | RenderReturnCodes | code, |
ON_wString & | out | ||
) | const |
|
virtual |
Description: Called br Render() when no meshes are added to scene. Returns: TRUE - If plug-in will render scene with no meshes FALSE - abort, nothing to render
RenderReturnCodes CRhinoSdkRender::RenderWindow | ( | const CRhinoCommandContext & | context, |
CRhinoView * | view, | ||
const LPRECT | rect, | ||
bool | bRenderInWindow | ||
) |
|
virtual |
Description: If your renderer supports pause / resume, override this method to resume rendering.
|
protected |
|
inlineprotected |
|
inlineprotected |
|
virtual |
Description: Called by RenderWindow when plug-in should start render processing. Parameters: view - [in] View user selected 2d render rectangle in. rect - [in] Screen rectangle user selected. Minimum size is 16x16 pixels. Returns: If false is returned then the Render() or RenderWindow() will abort.
|
inline |
|
virtual |
Description: Called by Render or RenderWindow() when a key press or mouse down event occurs during rendering. To interrupt rendering make ContinueModal() return false.
|
virtual |
Description: Override this method and return true if your renderer supports pause / resume.
|
friend |
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |
|
protected |