CRhinoUiFontComboBox.
More...
#include <RhinoSkdUiFontComboBox.h>
CRhinoUiFontComboBox.
- NoKeywords
/ / Copyright (c) 1993-2007 Robert McNeel & Associates. All rights reserved. / Rhinoceros is a registered trademark of Robert McNeel & Associates. / / THIS SOFTWARE IS PROVIDED "AS IS" WITHOUT EXPRESS OR IMPLIED WARRANTY. / ALL IMPLIED WARRANTIES OF FITNESS FOR ANY PARTICULAR PURPOSE AND OF / MERCHANTABILITY ARE HEREBY DISCLAIMED. /
/ For complete Rhino SDK copyright information see http://www.rhino3d.com/developer. / //////////////////////////////////////////////////////////////
◆ CRhinoUiFontComboBox()
CRhinoUiFontComboBox::CRhinoUiFontComboBox |
( |
| ) |
|
◆ ~CRhinoUiFontComboBox()
virtual CRhinoUiFontComboBox::~CRhinoUiFontComboBox |
( |
| ) |
|
|
virtual |
◆ _GetFontListIndex()
int CRhinoUiFontComboBox::_GetFontListIndex |
( |
LPCTSTR |
lpsFontFaceName | ) |
|
|
protected |
◆ CompareItem()
virtual int CRhinoUiFontComboBox::CompareItem |
( |
LPCOMPAREITEMSTRUCT |
| ) |
|
|
virtual |
◆ DrawDefault()
void CRhinoUiFontComboBox::DrawDefault |
( |
LPDRAWITEMSTRUCT |
| ) |
|
|
protected |
◆ DrawFont()
void CRhinoUiFontComboBox::DrawFont |
( |
LPDRAWITEMSTRUCT |
| ) |
|
|
protected |
◆ DrawItem()
virtual void CRhinoUiFontComboBox::DrawItem |
( |
LPDRAWITEMSTRUCT |
| ) |
|
|
virtual |
◆ FillFonts() [1/2]
void CRhinoUiFontComboBox::FillFonts |
( |
char * |
focus | ) |
|
◆ FillFonts() [2/2]
void CRhinoUiFontComboBox::FillFonts |
( |
wchar_t * |
focus = NULL | ) |
|
◆ GetFontListIndex() [1/2]
int CRhinoUiFontComboBox::GetFontListIndex |
( |
const char * |
lpsFontFaceName | ) |
|
◆ GetFontListIndex() [2/2]
int CRhinoUiFontComboBox::GetFontListIndex |
( |
const wchar_t * |
lpsFontFaceName | ) |
|
◆ GetLogfontFromListIndex()
LOGFONT* CRhinoUiFontComboBox::GetLogfontFromListIndex |
( |
int |
index | ) |
|
◆ GetSelFont()
int CRhinoUiFontComboBox::GetSelFont |
( |
LOGFONT & |
| ) |
|
◆ IgnoreZeroTypeFonts()
bool CRhinoUiFontComboBox::IgnoreZeroTypeFonts |
( |
| ) |
const |
◆ InitFonts()
void CRhinoUiFontComboBox::InitFonts |
( |
| ) |
|
|
protected |
◆ MeasureItem()
virtual void CRhinoUiFontComboBox::MeasureItem |
( |
LPMEASUREITEMSTRUCT |
| ) |
|
|
virtual |
◆ OnCreate()
afx_msg int CRhinoUiFontComboBox::OnCreate |
( |
LPCREATESTRUCT |
lpCreateStruct | ) |
|
◆ OnDestroy()
afx_msg void CRhinoUiFontComboBox::OnDestroy |
( |
| ) |
|
◆ OnlyShowTrueTypeFonts()
bool CRhinoUiFontComboBox::OnlyShowTrueTypeFonts |
( |
| ) |
const |
◆ SetHilightColors()
void CRhinoUiFontComboBox::SetHilightColors |
( |
COLORREF |
hilight, |
|
|
COLORREF |
hilightText |
|
) |
| |
◆ SetIgnoreZeroTypeFonts()
bool CRhinoUiFontComboBox::SetIgnoreZeroTypeFonts |
( |
bool |
value | ) |
|
◆ SetNormalColors()
void CRhinoUiFontComboBox::SetNormalColors |
( |
COLORREF |
clrBkgnd, |
|
|
COLORREF |
clrText |
|
) |
| |
◆ SetOnlyShowTrueTypeFonts()
bool CRhinoUiFontComboBox::SetOnlyShowTrueTypeFonts |
( |
bool |
b | ) |
|
◆ SetVaries()
void CRhinoUiFontComboBox::SetVaries |
( |
bool |
b | ) |
|
◆ Varies()
bool CRhinoUiFontComboBox::Varies |
( |
| ) |
|
◆ m_bInitOver
bool CRhinoUiFontComboBox::m_bInitOver |
|
protected |
◆ m_bTrueTypeOnly
bool CRhinoUiFontComboBox::m_bTrueTypeOnly |
|
protected |
◆ m_bVaries
bool CRhinoUiFontComboBox::m_bVaries |
|
protected |
Added varies support 8/2/07 LW.
◆ m_clrBkgnd
COLORREF CRhinoUiFontComboBox::m_clrBkgnd |
|
protected |
◆ m_clrHilight
COLORREF CRhinoUiFontComboBox::m_clrHilight |
|
protected |
◆ m_clrHilightText
COLORREF CRhinoUiFontComboBox::m_clrHilightText |
|
protected |
◆ m_clrNormalText
COLORREF CRhinoUiFontComboBox::m_clrNormalText |
|
protected |
◆ m_font_list
CPtrArray CRhinoUiFontComboBox::m_font_list |