#include <rhinoSdkView.h>
◆ CRhinoViewIterator()
CRhinoViewIterator::CRhinoViewIterator |
( |
unsigned int |
rhino_doc_sn | ) |
|
Parameters: rhino_doc_sn - [in] 0: iterate all views of all documents. >0: iteration all views of the specified doc.
◆ CurrentView()
class CRhinoView* CRhinoViewIterator::CurrentView |
( |
| ) |
const |
Returns: The current value of the iterator. Remarks:
◆ CurrentViewRuntimeSerialNumber()
unsigned int CRhinoViewIterator::CurrentViewRuntimeSerialNumber |
( |
| ) |
const |
◆ DocRuntimeSerialNumber()
unsigned int CRhinoViewIterator::DocRuntimeSerialNumber |
( |
| ) |
const |
Example: Iteratate all views: unsigned int rhino_doc_sn = 0 or doc->RuntimeSerialNumber(); CRhinoDocIterator doc_it(rhino_doc_sn); for ( CRhinoView* rhino_view = view_it.First(); 0 != rhino_view; rhino_view = view_it.Next() ) { ... }
◆ First()
Returns: The first view that exists. Remarks: You may call First() multiple times on the same iterator. Example: for ( CRhinoView* view = view_it.First(); 0 != view; view = view_it.Next() ) { ... }
◆ Initialize()
void CRhinoViewIterator::Initialize |
( |
| ) |
|
Description: Sets the iterator so the next call to Next() will return the first view that exists. This is useful when it is not practical to call First() to begin the iteration through the views. Remarks: You may call Initialize() multiple times on the same iterator. Example: view_it.Initialize(); while ( CRhinoView* view = view_it.Next() ) { ... }
◆ Next()
Returns: The next view that exists. Remarks: