Rhino C++ API
8.13
|
< Sweep info for ellipsoid and cylindrical drawing. More...
#include <rhinoSdkWidget.h>
Classes | |
struct | CAngles |
< In radians. More... | |
Public Member Functions | |
CSweep () | |
Public Attributes | |
struct CRhinoWidgetGeometry::CSweep::CAngles | angles |
int | iHighlightLatMod |
Modulus for highlighting lines of latitude (e.g., 'off'=0, 'every'=1, 'every other'=2). More... | |
int | iHighlightLonMod |
Modulus for highlighting lines of longitude (e.g., 'off'=0, 'every'=1, 'every other'=2). More... | |
int | iNumLat |
Number of lines of latitude. More... | |
int | iNumLon |
Number of lines of longitude. More... | |
< Sweep info for ellipsoid and cylindrical drawing.
CRhinoWidgetGeometry::CSweep::CSweep | ( | ) |
struct CRhinoWidgetGeometry::CSweep::CAngles CRhinoWidgetGeometry::CSweep::angles |
int CRhinoWidgetGeometry::CSweep::iHighlightLatMod |
Modulus for highlighting lines of latitude (e.g., 'off'=0, 'every'=1, 'every other'=2).
int CRhinoWidgetGeometry::CSweep::iHighlightLonMod |
Modulus for highlighting lines of longitude (e.g., 'off'=0, 'every'=1, 'every other'=2).
int CRhinoWidgetGeometry::CSweep::iNumLat |
Number of lines of latitude.
int CRhinoWidgetGeometry::CSweep::iNumLon |
Number of lines of longitude.