Rhino C++ API
8.13
|
#include <RhinoSdkPages.h>
Public Member Functions | |
CRhinoWindowCreateOptions () | |
~CRhinoWindowCreateOptions () | |
void | EnglishCaption (const wchar_t *caption) |
ON_wString | EnglishCaption (void) const |
void | LocalizedCaption (const wchar_t *caption) |
ON_wString | LocalizedCaption (void) const |
RhinoWindowCreateOptions | Options () const |
void | Options (RhinoWindowCreateOptions options) |
class IRhinoWindow * | ParentWindow () const |
void | ParentWindow (class IRhinoWindow *parent) const |
RHINO_WINDOW_HANDLE | ParentWindowHandle () const |
void | ParentWindowHandle (RHINO_WINDOW_HANDLE windowHandle) const |
class CRhinoWindowCreateOptions
Description: Generic window representation.
CRhinoWindowCreateOptions::CRhinoWindowCreateOptions | ( | ) |
Description: Default constructor.
CRhinoWindowCreateOptions::~CRhinoWindowCreateOptions | ( | ) |
Description: Default destructor.
void CRhinoWindowCreateOptions::EnglishCaption | ( | const wchar_t * | caption | ) |
Description: Optional english caption
ON_wString CRhinoWindowCreateOptions::EnglishCaption | ( | void | ) | const |
void CRhinoWindowCreateOptions::LocalizedCaption | ( | const wchar_t * | caption | ) |
Description: Optional localized caption
ON_wString CRhinoWindowCreateOptions::LocalizedCaption | ( | void | ) | const |
RhinoWindowCreateOptions CRhinoWindowCreateOptions::Options | ( | ) | const |
Description: Create options, defaults to RhinoWindowCreateOptions::ChildPage
void CRhinoWindowCreateOptions::Options | ( | RhinoWindowCreateOptions | options | ) |
Description: Create options, defaults to RhinoWindowCreateOptions::ChildPage
class IRhinoWindow* CRhinoWindowCreateOptions::ParentWindow | ( | ) | const |
Description: Optional parent window
void CRhinoWindowCreateOptions::ParentWindow | ( | class IRhinoWindow * | parent | ) | const |
Description: Optional parent window
RHINO_WINDOW_HANDLE CRhinoWindowCreateOptions::ParentWindowHandle | ( | ) | const |
Description: Optional parent window
void CRhinoWindowCreateOptions::ParentWindowHandle | ( | RHINO_WINDOW_HANDLE | windowHandle | ) | const |
Description: Optional parent window