Rhino C++ API
8.13
|
#include <rhinoSdkAppSettings.h>
Public Member Functions | |
CRhinoZebraAnalysisSettings () | |
void | Defaults () |
void | LoadProfile (CRhinoProfileContext &pc) |
load from registry More... | |
bool | operator!= (const CRhinoZebraAnalysisSettings &other) const |
bool | operator== (const CRhinoZebraAnalysisSettings &other) const |
const wchar_t * | ProfileKey () const |
void | SaveProfile (CRhinoProfileContext &) const |
save in registry More... | |
void | Validate () |
clamp settings to valid values More... | |
Public Attributes | |
BYTE | m_show_isoparms |
ON_Color | m_stripe_color |
BYTE | m_stripe_direction |
0 = horizontal, 1 = vertical More... | |
int | m_stripe_thickness |
0 = thinnest ... 6 = thickest More... | |
BYTE | reserved [2] |
Static Public Attributes | |
static const CRhinoZebraAnalysisSettings | Default |
CRhinoZebraAnalysisSettings::CRhinoZebraAnalysisSettings | ( | ) |
void CRhinoZebraAnalysisSettings::Defaults | ( | ) |
void CRhinoZebraAnalysisSettings::LoadProfile | ( | CRhinoProfileContext & | pc | ) |
load from registry
bool CRhinoZebraAnalysisSettings::operator!= | ( | const CRhinoZebraAnalysisSettings & | other | ) | const |
bool CRhinoZebraAnalysisSettings::operator== | ( | const CRhinoZebraAnalysisSettings & | other | ) | const |
const wchar_t* CRhinoZebraAnalysisSettings::ProfileKey | ( | ) | const |
void CRhinoZebraAnalysisSettings::SaveProfile | ( | CRhinoProfileContext & | ) | const |
save in registry
void CRhinoZebraAnalysisSettings::Validate | ( | ) |
clamp settings to valid values
|
static |
BYTE CRhinoZebraAnalysisSettings::m_show_isoparms |
ON_Color CRhinoZebraAnalysisSettings::m_stripe_color |
BYTE CRhinoZebraAnalysisSettings::m_stripe_direction |
0 = horizontal, 1 = vertical
int CRhinoZebraAnalysisSettings::m_stripe_thickness |
0 = thinnest ... 6 = thickest
BYTE CRhinoZebraAnalysisSettings::reserved[2] |