Rhino C++ API
8.13
|
Interface class for forwarding dockbar events. More...
#include <RhinoSdkDialog.h>
Public Types | |
enum | ShowEventArgs : int { ShowEventArgs::Show, ShowEventArgs::Hide, ShowEventArgs::HideOnDeactivate, ShowEventArgs::ShowOnDeactivate } |
OnShowDockbar event type More... | |
Public Member Functions | |
virtual | ~IDockBarEventWatcher () |
virtual void | OnDockBarPositionChanged (DWORD dwNewLocation)=0 |
virtual bool | OnDockContextStartDrag (bool bStart)=0 |
virtual void | OnShowDockBar (ShowEventArgs args)=0 |
virtual void | OnStartTracking (bool bDoneTracking)=0 |
virtual void | OnToggleDocking (bool bStart)=0 |
Interface class for forwarding dockbar events.
|
strong |
OnShowDockbar event type
|
inlinevirtual |
|
pure virtual |
Implemented in CRhinoTabbedDockBarDialog.
|
pure virtual |
Implemented in CRhinoTabbedDockBarDialog.
|
pure virtual |
Implemented in CRhinoTabbedDockBarDialog.
|
pure virtual |
Implemented in CRhinoTabbedDockBarDialog.
|
pure virtual |
Implemented in CRhinoTabbedDockBarDialog.