Rhino C++ API  8.6
Public Member Functions | List of all members
IRhRdkAngleDialDecorator Class Referenceabstract

#include <RhRdkAngleCtrl.h>

Public Member Functions

virtual ~IRhRdkAngleDialDecorator ()
 
virtual void DeleteThis (void)=0
 
virtual void DialColors (CRhRdkColor &colOut1, CRhRdkColor &colOut2) const =0
 
virtual void Draw (HDC dc, const ON_4iRect &dialRect, double dRadius, double dAngle, bool bEnabled, bool bHot) const =0
 
virtual void * EVF (const wchar_t *, void *)=0
 
virtual IRhRdkAngleDialDecoratorNextDecorator (void) const =0
 

Detailed Description

Implement this interface to provide decoration for the dial of an angle control.

See also
CRhRdkAngleCtrl

Constructor & Destructor Documentation

◆ ~IRhRdkAngleDialDecorator()

virtual IRhRdkAngleDialDecorator::~IRhRdkAngleDialDecorator ( )
inlinevirtual

Member Function Documentation

◆ DeleteThis()

virtual void IRhRdkAngleDialDecorator::DeleteThis ( void  )
pure virtual

You must implement this method as

delete this;

◆ DialColors()

virtual void IRhRdkAngleDialDecorator::DialColors ( CRhRdkColor colOut1,
CRhRdkColor colOut2 
) const
pure virtual

Implement this method to override the default dial colors when the style is kUnmarked, kCompass or kAzimuth. If you don't want to override the dial colors, implement a no-op stub.

See also
CRhRdkAngleCtrl::SetDialColors().

◆ Draw()

virtual void IRhRdkAngleDialDecorator::Draw ( HDC  dc,
const ON_4iRect dialRect,
double  dRadius,
double  dAngle,
bool  bEnabled,
bool  bHot 
) const
pure virtual

Implement this method to draw the decoration.

Parameters
dcis the device context to draw into.
dialRectis the rectangle of the dial.
dRadiusis the radius of the dial.
dAngleis the angle being displayed by the control.
bEnabledis true if the control is enabled, else false.
bHotis true if the decoration should be drawn in hot-tracked style.

◆ EVF()

virtual void* IRhRdkAngleDialDecorator::EVF ( const wchar_t *  ,
void *   
)
pure virtual

Emergency virtual function for future expansion.

◆ NextDecorator()

virtual IRhRdkAngleDialDecorator* IRhRdkAngleDialDecorator::NextDecorator ( void  ) const
pure virtual

Implement this method to return a pointer to an optional next decorator. This allows decorators to be chained together. Return null if not needed.