Rhino C++ API  8.5
Public Member Functions | List of all members
IRhRdkContentIOPlugIns Class Referenceabstract

#include <IRhRdkContentIOPlugIns.h>

Public Member Functions

virtual ~IRhRdkContentIOPlugIns ()
 
virtual void * EVF (const wchar_t *, void *)=0
 
virtual CRhRdkContentIOPlugInFind (const ON_wString &sExtension) const =0
 
virtual CRhRdkContentIOPlugInFirst (void) const =0
 
virtual CRhRdkContentIOPlugInNext (void) const =0
 

Detailed Description

This interface represents the collection of all content I/O plug-ins that are known to the RDK.

Constructor & Destructor Documentation

◆ ~IRhRdkContentIOPlugIns()

virtual IRhRdkContentIOPlugIns::~IRhRdkContentIOPlugIns ( )
inlinevirtual

Member Function Documentation

◆ EVF()

virtual void* IRhRdkContentIOPlugIns::EVF ( const wchar_t *  ,
void *   
)
pure virtual

Emergency virtual function for future expansion.

◆ Find()

virtual CRhRdkContentIOPlugIn* IRhRdkContentIOPlugIns::Find ( const ON_wString sExtension) const
pure virtual

Find a content I/O plug-in by its file extension.

Returns
A pointer to the I/O plug-in or NULL if no plug-in supports the extension.

◆ First()

virtual CRhRdkContentIOPlugIn* IRhRdkContentIOPlugIns::First ( void  ) const
pure virtual

Get a pointer to the first content I/O plug-in in the collection.

Returns
A pointer to the first content I/O plug-in or NULL if there are none.

◆ Next()

virtual CRhRdkContentIOPlugIn* IRhRdkContentIOPlugIns::Next ( void  ) const
pure virtual

Get a pointer to the next content I/O plug-in in the collection.

Returns
A pointer to the next I/O plug-in or NULL if no more.