Rhino C++ API
8.13
|
#include <IRhRdkDithering.h>
Public Types | |
enum | Methods : unsigned int { Methods::None, Methods::FloydSteinberg, Methods::SimpleNoise } |
Dithering algorithm. More... | |
Public Member Functions | |
virtual | ~IRhRdkDithering () |
virtual IRhRdkDithering & | BeginChange (RhRdkChangeContext cc) const =0 |
virtual void | CopyFrom (const IRhRdkDithering &dit)=0 |
virtual bool | EndChange (void)=0 |
virtual void * | EVF (const wchar_t *wszFunc, void *pvData)=0 |
virtual bool | IsEqual (const IRhRdkDithering &dit) const =0 |
virtual Methods | Method (void) const =0 |
bool | On (void) const |
virtual void | SetMethod (Methods m)=0 |
void | SetOn (bool bOn) |
Static Public Member Functions | |
static IRhRdkDithering * | New (void) |
This interface is deprecated and only kept for backward compatibility.
|
strong |
|
inlinevirtual |
|
pure virtual |
Call this method to get a non-const object upon which you can call non-const methods. Calls to this method are counted; you must call EndChange() once for every call to BeginChange(). Please do not use const_cast or any other means of circumventing this requirement.
|
pure virtual |
Copy another dithering object to this one.
|
pure virtual |
|
pure virtual |
Emergency virtual function for future expansion. Currently implemented wszFunc: "On" (pvData = null; returns pointer to bool). "SetOn" (pvData is pointer to bool).
|
pure virtual |
|
pure virtual |
Get the dithering method
|
static |
bool IRhRdkDithering::On | ( | void | ) | const |
|
pure virtual |
Set the dithering method
void IRhRdkDithering::SetOn | ( | bool | bOn | ) |