Rhino C++ API
8.18
Main Page
Related Pages
Modules
Classes
Class List
Class Index
Class Hierarchy
Class Members
All
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
~
Functions
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
~
Variables
_
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
Typedefs
Enumerations
a
b
c
d
e
f
g
h
i
k
l
m
n
o
p
q
r
s
t
u
v
w
Enumerator
a
b
c
d
e
f
g
h
i
j
k
l
m
n
o
p
q
r
s
t
u
v
w
x
y
z
Related Functions
c
d
g
i
o
q
r
s
t
•
All
Classes
Namespaces
Functions
Variables
Typedefs
Enumerations
Enumerator
Friends
Modules
Pages
IRhRdkGroundPlane Member List
This is the complete list of members for
IRhRdkGroundPlane
, including all inherited members.
Altitude
(void) const =0
IRhRdkGroundPlane
pure virtual
AutoAltitude
(void) const =0
IRhRdkGroundPlane
pure virtual
BeginChange
(RhRdkChangeContext cc) const =0
IRhRdkGroundPlane
pure virtual
BeginNotifyBracket
(void)=0
IRhRdkGroundPlane
pure virtual
CopyFrom
(const IRhRdkGroundPlane &gp)=0
IRhRdkGroundPlane
pure virtual
Enabled
(void) const
IRhRdkGroundPlane
inline
EndChange
(void)=0
IRhRdkGroundPlane
pure virtual
EndNotifyBracket
(void)=0
IRhRdkGroundPlane
pure virtual
EVF
(const wchar_t *, void *)=0
IRhRdkGroundPlane
pure virtual
IsEqual
(const IRhRdkGroundPlane &gp) const =0
IRhRdkGroundPlane
pure virtual
Material
(void) const =0
IRhRdkGroundPlane
pure virtual
MaterialInstanceId
(void) const =0
IRhRdkGroundPlane
pure virtual
New
(void)
IRhRdkGroundPlane
static
On
(void) const =0
IRhRdkGroundPlane
pure virtual
SetAltitude
(double)=0
IRhRdkGroundPlane
pure virtual
SetAutoAltitude
(bool)=0
IRhRdkGroundPlane
pure virtual
SetEnabled
(bool b)
IRhRdkGroundPlane
inline
SetMaterialInstanceId
(const UUID &)=0
IRhRdkGroundPlane
pure virtual
SetOn
(bool)=0
IRhRdkGroundPlane
pure virtual
SetShadowOnly
(bool)=0
IRhRdkGroundPlane
pure virtual
SetShowUnderside
(bool)=0
IRhRdkGroundPlane
pure virtual
SetTextureOffset
(const ON_2dVector &)=0
IRhRdkGroundPlane
pure virtual
SetTextureOffsetLocked
(bool)=0
IRhRdkGroundPlane
pure virtual
SetTextureRepeatLocked
(bool)=0
IRhRdkGroundPlane
pure virtual
SetTextureRotation
(double)=0
IRhRdkGroundPlane
pure virtual
SetTextureSize
(const ON_2dVector &)=0
IRhRdkGroundPlane
pure virtual
SetTextureSizeLocked
(bool b)
IRhRdkGroundPlane
inline
ShadowOnly
(void) const =0
IRhRdkGroundPlane
pure virtual
ShowUnderside
(void) const =0
IRhRdkGroundPlane
pure virtual
TextureOffset
(void) const =0
IRhRdkGroundPlane
pure virtual
TextureOffsetLocked
(void) const =0
IRhRdkGroundPlane
pure virtual
TextureRepeatLocked
(void) const =0
IRhRdkGroundPlane
pure virtual
TextureRotation
(void) const =0
IRhRdkGroundPlane
pure virtual
TextureSize
(void) const =0
IRhRdkGroundPlane
pure virtual
TextureSizeLocked
(void) const
IRhRdkGroundPlane
inline
~IRhRdkGroundPlane
()
IRhRdkGroundPlane
inline
virtual
Generated on Tue Apr 8 2025 16:24:01 for Rhino C++ API by
1.8.17