Rhino C++ API  8.6
Public Member Functions | Static Public Member Functions | List of all members
IRhRdkGroundPlane Class Referenceabstract

#include <IRhRdkGroundPlane.h>

Public Member Functions

virtual ~IRhRdkGroundPlane ()
 
virtual double Altitude (void) const =0
 
virtual bool AutoAltitude (void) const =0
 
virtual IRhRdkGroundPlaneBeginChange (RhRdkChangeContext cc) const =0
 
virtual void BeginNotifyBracket (void)=0
 
virtual void CopyFrom (const IRhRdkGroundPlane &gp)=0
 
bool Enabled (void) const
 
virtual bool EndChange (void)=0
 
virtual void EndNotifyBracket (void)=0
 
virtual void * EVF (const wchar_t *, void *)=0
 
virtual bool IsEqual (const IRhRdkGroundPlane &gp) const =0
 
virtual const class CRhRdkMaterialMaterial (void) const =0
 
virtual UUID MaterialInstanceId (void) const =0
 
virtual bool On (void) const =0
 
virtual void SetAltitude (double)=0
 
virtual void SetAutoAltitude (bool)=0
 
void SetEnabled (bool b)
 
virtual void SetMaterialInstanceId (const UUID &)=0
 
virtual void SetOn (bool)=0
 
virtual void SetShadowOnly (bool)=0
 
virtual void SetShowUnderside (bool)=0
 
virtual void SetTextureOffset (const ON_2dVector &)=0
 
virtual void SetTextureOffsetLocked (bool)=0
 
virtual void SetTextureRepeatLocked (bool)=0
 
virtual void SetTextureRotation (double)=0
 
virtual void SetTextureSize (const ON_2dVector &)=0
 
void SetTextureSizeLocked (bool b)
 
virtual bool ShadowOnly (void) const =0
 
virtual bool ShowUnderside (void) const =0
 
virtual ON_2dVector TextureOffset (void) const =0
 
virtual bool TextureOffsetLocked (void) const =0
 
virtual bool TextureRepeatLocked (void) const =0
 
virtual double TextureRotation (void) const =0
 
virtual ON_2dVector TextureSize (void) const =0
 
bool TextureSizeLocked (void) const
 

Static Public Member Functions

static IRhRdkGroundPlaneNew (void)
 

Detailed Description

This interface is deprecated and only kept for backward compatibility.

Constructor & Destructor Documentation

◆ ~IRhRdkGroundPlane()

virtual IRhRdkGroundPlane::~IRhRdkGroundPlane ( )
inlinevirtual

Member Function Documentation

◆ Altitude()

virtual double IRhRdkGroundPlane::Altitude ( void  ) const
pure virtual
Returns
The altitude of the ground plane.

◆ AutoAltitude()

virtual bool IRhRdkGroundPlane::AutoAltitude ( void  ) const
pure virtual
Returns
true if auto-altitude is enabled.

◆ BeginChange()

virtual IRhRdkGroundPlane& IRhRdkGroundPlane::BeginChange ( RhRdkChangeContext  cc) const
pure virtual

Call this method to get a non-const object upon which you can call non-const methods. Calls to this method are counted; you must call EndChange() once for every call to BeginChange(). Please do not use const_cast or any other means of circumventing this requirement.

◆ BeginNotifyBracket()

virtual void IRhRdkGroundPlane::BeginNotifyBracket ( void  )
pure virtual

Call this before calling multiple 'Set' methods.

◆ CopyFrom()

virtual void IRhRdkGroundPlane::CopyFrom ( const IRhRdkGroundPlane gp)
pure virtual

Copy this ground plane from another one.

◆ Enabled()

bool IRhRdkGroundPlane::Enabled ( void  ) const
inline

◆ EndChange()

virtual bool IRhRdkGroundPlane::EndChange ( void  )
pure virtual

◆ EndNotifyBracket()

virtual void IRhRdkGroundPlane::EndNotifyBracket ( void  )
pure virtual

Call this after calling multiple 'Set' methods.

◆ EVF()

virtual void* IRhRdkGroundPlane::EVF ( const wchar_t *  ,
void *   
)
pure virtual

Emergency virtual function for future expansion.

◆ IsEqual()

virtual bool IRhRdkGroundPlane::IsEqual ( const IRhRdkGroundPlane gp) const
pure virtual
Returns
true if this ground plane is equal to another one.

◆ Material()

virtual const class CRhRdkMaterial* IRhRdkGroundPlane::Material ( void  ) const
pure virtual
Returns
A pointer to the ground plane's material or null if none.

◆ MaterialInstanceId()

virtual UUID IRhRdkGroundPlane::MaterialInstanceId ( void  ) const
pure virtual
Returns
The instance id of the ground plane's material.

◆ New()

static IRhRdkGroundPlane* IRhRdkGroundPlane::New ( void  )
static

◆ On()

virtual bool IRhRdkGroundPlane::On ( void  ) const
pure virtual
Returns
true if the ground plane is enabled, else false.

◆ SetAltitude()

virtual void IRhRdkGroundPlane::SetAltitude ( double  )
pure virtual

Set the ground plane's altitude.

◆ SetAutoAltitude()

virtual void IRhRdkGroundPlane::SetAutoAltitude ( bool  )
pure virtual

Set if the ground plane is set to auto-altitude.

◆ SetEnabled()

void IRhRdkGroundPlane::SetEnabled ( bool  b)
inline

◆ SetMaterialInstanceId()

virtual void IRhRdkGroundPlane::SetMaterialInstanceId ( const UUID &  )
pure virtual

Set the instance id of the ground plane's material.

◆ SetOn()

virtual void IRhRdkGroundPlane::SetOn ( bool  )
pure virtual

Set the ground plane enabled state.

◆ SetShadowOnly()

virtual void IRhRdkGroundPlane::SetShadowOnly ( bool  )
pure virtual

Set if the ground plane is set to shadow-only.

◆ SetShowUnderside()

virtual void IRhRdkGroundPlane::SetShowUnderside ( bool  )
pure virtual

Set if the ground plane backface is enabled.

◆ SetTextureOffset()

virtual void IRhRdkGroundPlane::SetTextureOffset ( const ON_2dVector )
pure virtual

Set the texture offset of the ground plane in model units.

◆ SetTextureOffsetLocked()

virtual void IRhRdkGroundPlane::SetTextureOffsetLocked ( bool  )
pure virtual

Set if the texture offset x and y are locked together.

◆ SetTextureRepeatLocked()

virtual void IRhRdkGroundPlane::SetTextureRepeatLocked ( bool  )
pure virtual

Set if the texture repeat x and y are locked together.

◆ SetTextureRotation()

virtual void IRhRdkGroundPlane::SetTextureRotation ( double  )
pure virtual

Set the texture rotation of the ground plane in degrees.

◆ SetTextureSize()

virtual void IRhRdkGroundPlane::SetTextureSize ( const ON_2dVector )
pure virtual

Set the texture size of the ground plane in model units.

◆ SetTextureSizeLocked()

void IRhRdkGroundPlane::SetTextureSizeLocked ( bool  b)
inline

◆ ShadowOnly()

virtual bool IRhRdkGroundPlane::ShadowOnly ( void  ) const
pure virtual
Returns
true if the ground plane is set to shadow-only.

◆ ShowUnderside()

virtual bool IRhRdkGroundPlane::ShowUnderside ( void  ) const
pure virtual
Returns
true if ground plane backface is enabled, else false.

◆ TextureOffset()

virtual ON_2dVector IRhRdkGroundPlane::TextureOffset ( void  ) const
pure virtual
Returns
The texture offset of the ground plane in model units.

◆ TextureOffsetLocked()

virtual bool IRhRdkGroundPlane::TextureOffsetLocked ( void  ) const
pure virtual
Returns
true if the texture offset x and y are locked together.

◆ TextureRepeatLocked()

virtual bool IRhRdkGroundPlane::TextureRepeatLocked ( void  ) const
pure virtual
Returns
true if the texture repeat x and y are locked together.

◆ TextureRotation()

virtual double IRhRdkGroundPlane::TextureRotation ( void  ) const
pure virtual
Returns
The texture rotation of the ground plane in degrees.

◆ TextureSize()

virtual ON_2dVector IRhRdkGroundPlane::TextureSize ( void  ) const
pure virtual
Returns
The texture size of the ground plane in model units.

◆ TextureSizeLocked()

bool IRhRdkGroundPlane::TextureSizeLocked ( void  ) const
inline