Rhino C++ API
8.13
|
#include <IRhRdkMenu.h>
Public Member Functions | |
virtual | ~IRhRdkMenu () |
virtual bool | AddItem (const UUID &uuidAction)=0 |
virtual bool | AddItem (const wchar_t *wszCaption, unsigned short cmd, bool bEnabled)=0 |
virtual void | AddSeparator (void)=0 |
virtual IRhRdkMenu & | AddSubMenu (const wchar_t *wszCaption)=0 |
virtual void * | EVF (const wchar_t *, void *)=0 |
This interface allows access to menus created or managed by the RDK. It is used by the RDK UI plug-in to get menus from the core RDK.
|
inlinevirtual |
|
pure virtual |
This method is obsolete.
|
pure virtual |
Add a menu item to the menu.
wszCaption | is the menu item's caption. |
cmd | is the menu item's command id |
bEnabled | is the menu item's enable state. |
|
pure virtual |
Add a separator to the menu.
|
pure virtual |
Add a sub-menu to the menu.
wszCaption | is the sub-menu's caption. |
|
pure virtual |
Emergency virtual function for future expansion.