Rhino C++ API  8.6
Public Member Functions | List of all members
IRhRdkParamTransport Class Referenceabstract

#include <IRhRdkParamTransport.h>

Public Member Functions

virtual ~IRhRdkParamTransport ()
 
virtual void AddParamsToParamBlock (IRhRdkParamBlock &paramBlock) const =0
 
virtual ON_wString Caption (void) const =0
 
virtual void * EVF (const wchar_t *, void *)=0
 
virtual void GetParamsFromParamBlock (const IRhRdkParamBlock &paramBlock)=0
 

Detailed Description

This interface makes the connection between RDK's automatic user interface and your RDK plug-in. You must implement this interface if you want to use RDK's automatic user interface services.

Constructor & Destructor Documentation

◆ ~IRhRdkParamTransport()

virtual IRhRdkParamTransport::~IRhRdkParamTransport ( )
inlinevirtual

Member Function Documentation

◆ AddParamsToParamBlock()

virtual void IRhRdkParamTransport::AddParamsToParamBlock ( IRhRdkParamBlock paramBlock) const
pure virtual

Implement this method to initially add your parameters to the param block.

◆ Caption()

virtual ON_wString IRhRdkParamTransport::Caption ( void  ) const
pure virtual

Implement this method to return a caption string for the ui section.

◆ EVF()

virtual void* IRhRdkParamTransport::EVF ( const wchar_t *  ,
void *   
)
pure virtual

Emergency virtual function for future expansion.

◆ GetParamsFromParamBlock()

virtual void IRhRdkParamTransport::GetParamsFromParamBlock ( const IRhRdkParamBlock paramBlock)
pure virtual

Implement this method to retrieve the updated parameters after the user has made a change to one of them.