Rhino C++ API
8.13
|
#include <RhRdkNewPostEffectPlugIn.h>
Public Member Functions | |
virtual | ~IRhRdkPostEffectCollection () |
virtual void * | EVF (const wchar_t *wszFunc, void *pvData)=0 |
virtual void | GetPostEffects (IRhRdkPostEffect::Types type, OUT ON_SimpleArray< IRhRdkPostEffect * > &a) const =0 |
virtual IRhRdkPostEffect * | PostEffectFromId (const UUID &uuidPostEffect) const =0 |
This interface provides access to all the post effects that are available from a data source. Post effects are classified by having a type of 'early', 'tone mapping', or 'late'. Each of these sets can be accessed separately as each has slightly different specializations.
|
inlinevirtual |
|
pure virtual |
|
pure virtual |
|
pure virtual |