#include <IRhRdkPostEffectImage.h>
|
virtual | ~IRhRdkPostEffectImage () |
|
virtual BYTE * | Bits (void) const =0 |
|
virtual DWORD | BitsPerPixel (void) const =0 |
|
virtual eRhRdkPepByteOrder | ByteOrder (void) const =0 |
|
virtual bool | ChannelInformationAvailable (const UUID &uuidChannel) const =0 |
|
virtual void * | EVF (const wchar_t *, void *)=0 |
|
virtual bool | GetChannelValue (const UUID &uuidChannel, int x, int y, float &fValueOut) const =0 |
|
virtual bool | GetChannelValues (const UUID *aUuidChannels, int x, int y, float *aValuesOut, int iNumberOfValues) const =0 |
|
virtual bool | GetDIBPixel (int x, int y, float &fRedOut, float &fGreenOut, float &fBlueOut) const =0 |
|
virtual bool | GetMinMaxValuesFromChannel (const UUID &uuidChannel, float &fMinOut, float &fMaxOut) const =0 |
|
virtual DWORD | Height (void) const =0 |
|
virtual bool | Inverted (void) const =0 |
|
virtual bool | IsPickPointOnImageImplemented (void) const =0 |
|
virtual bool | IsPickRectangleOnImageImplemented (void) const =0 |
|
virtual bool | IsProcessInterrupted (void) const =0 |
|
virtual DWORD | LineLength (void) const =0 |
|
virtual IRhRdkRenderWindow::IChannel * | NewChannel (const UUID &uuidChannel) const =0 |
|
virtual void | OnProcessImageBegin (const wchar_t *wszPlugIn) const =0 |
|
virtual void | OnProcessImageEnd (const wchar_t *wszPlugIn) const =0 |
|
virtual void | OnProcessImageProgress (const wchar_t *wszPlugIn, float fProgress) const =0 |
|
virtual bool | PickPointOnImage (int &x, int &y, HCURSOR hCursor) const =0 |
|
virtual bool | PickRectangleOnImage (ON_4iRect &rectOut, HCURSOR hCursor) const =0 |
|
virtual bool | UpdateImage (void)=0 |
|
virtual DWORD | Width (void) const =0 |
|
◆ ~IRhRdkPostEffectImage()
virtual IRhRdkPostEffectImage::~IRhRdkPostEffectImage |
( |
| ) |
|
|
inlinevirtual |
◆ Bits()
virtual BYTE* IRhRdkPostEffectImage::Bits |
( |
void |
| ) |
const |
|
pure virtual |
- Returns
- A pointer to the bits in the image DIB.
◆ BitsPerPixel()
virtual DWORD IRhRdkPostEffectImage::BitsPerPixel |
( |
void |
| ) |
const |
|
pure virtual |
- Returns
- The number of bits in each image pixel.
◆ ByteOrder()
- Returns
- The length in bytes of one image pixel line.
◆ ChannelInformationAvailable()
virtual bool IRhRdkPostEffectImage::ChannelInformationAvailable |
( |
const UUID & |
uuidChannel | ) |
const |
|
pure virtual |
Query whether or not information is available for a given channel.
- Parameters
-
uuidChannel | specifies the channel of interest. |
- Returns
- true if the image contains information for the specified channel, else false.
◆ EVF()
virtual void* IRhRdkPostEffectImage::EVF |
( |
const wchar_t * |
, |
|
|
void * |
|
|
) |
| |
|
pure virtual |
Emergency virtual function for future expansion.
◆ GetChannelValue()
virtual bool IRhRdkPostEffectImage::GetChannelValue |
( |
const UUID & |
uuidChannel, |
|
|
int |
x, |
|
|
int |
y, |
|
|
float & |
fValueOut |
|
) |
| const |
|
pure virtual |
Get a channel value from the image.
- Parameters
-
uuidChannel | specifies the channel of interest. |
x | is the horizontal pixel position. |
y | is the vertical pixel position. |
fValueOut | accepts the channel value. |
- Returns
- true if successful, else false.
◆ GetChannelValues()
virtual bool IRhRdkPostEffectImage::GetChannelValues |
( |
const UUID * |
aUuidChannels, |
|
|
int |
x, |
|
|
int |
y, |
|
|
float * |
aValuesOut, |
|
|
int |
iNumberOfValues |
|
) |
| const |
|
pure virtual |
Get multiple channel values from the image.
- Parameters
-
aUuidChannels | is an array specifying the channels of interest. |
x | is the horizontal pixel position. |
y | is the vertical pixel position. |
aValuesOut | accepts the channel values in the same order as aUuidChannels. |
iNumberOfValues | is the number of channels to retrieve. aUuidChannels and aValuesOut must have this many elements. |
- Returns
- true if successful, else false.
◆ GetDIBPixel()
virtual bool IRhRdkPostEffectImage::GetDIBPixel |
( |
int |
x, |
|
|
int |
y, |
|
|
float & |
fRedOut, |
|
|
float & |
fGreenOut, |
|
|
float & |
fBlueOut |
|
) |
| const |
|
pure virtual |
Get an RGB pixel from the image.
- Parameters
-
x | is the horizontal pixel position. |
y | is the vertical pixel position. |
fRedOut | accepts the red channel value. |
fGreenOut | accepts the green channel value. |
fBlueOut | accepts the blue channel value. |
- Returns
- true if successful, else false.
◆ GetMinMaxValuesFromChannel()
virtual bool IRhRdkPostEffectImage::GetMinMaxValuesFromChannel |
( |
const UUID & |
uuidChannel, |
|
|
float & |
fMinOut, |
|
|
float & |
fMaxOut |
|
) |
| const |
|
pure virtual |
Get minimum and maximum values from a channel in the image.
- Parameters
-
uuidChannel | specifies the channel of interest. |
fMinOut | accepts the minimum value. |
fMaxOut | accepts the maximum value. |
- Returns
- true if the image contains information for the specified channel, else false.
◆ Height()
virtual DWORD IRhRdkPostEffectImage::Height |
( |
void |
| ) |
const |
|
pure virtual |
- Returns
- The height of the image.
◆ Inverted()
virtual bool IRhRdkPostEffectImage::Inverted |
( |
void |
| ) |
const |
|
pure virtual |
- Returns
- true if the image is inverted (bottom-up DIB), else false.
◆ IsPickPointOnImageImplemented()
virtual bool IRhRdkPostEffectImage::IsPickPointOnImageImplemented |
( |
void |
| ) |
const |
|
pure virtual |
- Returns
- true if picking a point on this image is implemented, else false.
◆ IsPickRectangleOnImageImplemented()
virtual bool IRhRdkPostEffectImage::IsPickRectangleOnImageImplemented |
( |
void |
| ) |
const |
|
pure virtual |
- Returns
- true if picking a rectangle on this image is implemented, else false.
◆ IsProcessInterrupted()
virtual bool IRhRdkPostEffectImage::IsProcessInterrupted |
( |
void |
| ) |
const |
|
pure virtual |
Called periodically during post-processing the image to determine if the user cancelled the process.
- Returns
- true if the user cancelled the process, else false.
◆ LineLength()
virtual DWORD IRhRdkPostEffectImage::LineLength |
( |
void |
| ) |
const |
|
pure virtual |
- Returns
- The length in bytes (DWORD-aligned) of one image pixel line.
◆ NewChannel()
◆ OnProcessImageBegin()
virtual void IRhRdkPostEffectImage::OnProcessImageBegin |
( |
const wchar_t * |
wszPlugIn | ) |
const |
|
pure virtual |
Called at the start of post-processing the image.
- Parameters
-
wszPlugIn | is the name of the post-effect plug-in. |
◆ OnProcessImageEnd()
virtual void IRhRdkPostEffectImage::OnProcessImageEnd |
( |
const wchar_t * |
wszPlugIn | ) |
const |
|
pure virtual |
Called at the end of post-processing the image.
- Parameters
-
wszPlugIn | is the name of the post-effect plug-in. |
◆ OnProcessImageProgress()
virtual void IRhRdkPostEffectImage::OnProcessImageProgress |
( |
const wchar_t * |
wszPlugIn, |
|
|
float |
fProgress |
|
) |
| const |
|
pure virtual |
Called periodically during post-processing of the image.
- Parameters
-
wszPlugIn | is the name of the post-effect plug-in. |
fProgress | is the amount of progress made so far (0.0 to 1.0). |
◆ PickPointOnImage()
virtual bool IRhRdkPostEffectImage::PickPointOnImage |
( |
int & |
x, |
|
|
int & |
y, |
|
|
HCURSOR |
hCursor |
|
) |
| const |
|
pure virtual |
Allows the user to pick a point on the image.
- Parameters
-
x | receives the picked horizontal pixel position. |
y | receives the picked vertical pixel position. |
hCursor | is obsolete and is not used. |
- Returns
- true if successful, else false.
◆ PickRectangleOnImage()
virtual bool IRhRdkPostEffectImage::PickRectangleOnImage |
( |
ON_4iRect & |
rectOut, |
|
|
HCURSOR |
hCursor |
|
) |
| const |
|
pure virtual |
Allows the user to pick a rectangle on the image.
- Parameters
-
rectOut | receives the picked rectangle. |
hCursor | is obsolete and is not used. |
- Returns
- true if successful, else false.
◆ UpdateImage()
virtual bool IRhRdkPostEffectImage::UpdateImage |
( |
void |
| ) |
|
|
pure virtual |
Updates the image by applying the post-effects to it.
◆ Width()
virtual DWORD IRhRdkPostEffectImage::Width |
( |
void |
| ) |
const |
|
pure virtual |
- Returns
- The width of the image.