#include <IRhRdkSectionHolder.h>
|
static CRhRdkVariant | GetParameter (const IRhinoUiWithController &ui, const UUID &uuidPostEffect, const wchar_t *wszName, const CRhRdkVariant &vDefault) |
|
static void | GetPostEffects (const IRhinoUiWithController &ui, const UUID &uuidPostEffect, ON_SimpleArray< const IRhRdkPostEffect * > &aPostEffects) |
|
static void | GetPostEffects (const IRhinoUiWithController &ui, IRhRdkPostEffect::Types type, ON_SimpleArray< const IRhRdkPostEffect * > &aPostEffects) |
|
static bool | SetParameter (const IRhinoUiWithController &ui, const UUID &uuidPostEffect, const wchar_t *wszName, const CRhRdkVariant &vValue) |
|
◆ ~IRhRdkPostEffectSection()
virtual IRhRdkPostEffectSection::~IRhRdkPostEffectSection |
( |
| ) |
|
|
inlineprotectedvirtual |
◆ EVF()
virtual void* IRhRdkPostEffectSection::EVF |
( |
const wchar_t * |
wszFunc, |
|
|
void * |
pvData |
|
) |
| |
|
pure virtual |
Emergency virtual function for future expansion.
◆ GetParameter() [1/2]
◆ GetParameter() [2/2]
Implement this method to return a named post effect parameter.
◆ GetPostEffects() [1/3]
◆ GetPostEffects() [2/3]
◆ GetPostEffects() [3/3]
Get the post effects using this section. Currently, this returns only one item.
◆ PostEffectId()
virtual UUID IRhRdkPostEffectSection::PostEffectId |
( |
void |
| ) |
const |
|
pure virtual |
Implement this method to return the id of your post effect.
◆ SetParameter() [1/2]
◆ SetParameter() [2/2]
virtual bool IRhRdkPostEffectSection::SetParameter |
( |
const wchar_t * |
wszName, |
|
|
const CRhRdkVariant & |
vValue |
|
) |
| |
|
pure virtual |
Implement this method to set a named post effect parameter.