Rhino C++ API  8.6
Classes | Public Member Functions | Protected Member Functions | List of all members
IRhRdkPostEffectThreadEngine::IJob Class Referenceabstract

#include <RhRdkNewPostEffectPlugIn.h>

Classes

class  IChannels
 

Public Member Functions

virtual IJobClone (void) const =0
 
virtual void DeleteThis (void)=0
 
virtual void * EVF (const wchar_t *, void *)=0
 
virtual bool Execute (const ON_4iRect &rect, IChannels &chans)=0
 

Protected Member Functions

virtual ~IJob ()
 

Detailed Description

Represents a job queued in the thread engine system. A post effect implements this interface to do its processing.

Constructor & Destructor Documentation

◆ ~IJob()

virtual IRhRdkPostEffectThreadEngine::IJob::~IJob ( )
inlineprotectedvirtual

Member Function Documentation

◆ Clone()

virtual IJob* IRhRdkPostEffectThreadEngine::IJob::Clone ( void  ) const
pure virtual

This method must be implemented as

return new CMyJob(...);

.

Returns
a clone of the job object.

◆ DeleteThis()

virtual void IRhRdkPostEffectThreadEngine::IJob::DeleteThis ( void  )
pure virtual

You must implement this method as

delete this;

◆ EVF()

virtual void* IRhRdkPostEffectThreadEngine::IJob::EVF ( const wchar_t *  ,
void *   
)
pure virtual

Emergency virtual function for future expansion.

◆ Execute()

virtual bool IRhRdkPostEffectThreadEngine::IJob::Execute ( const ON_4iRect rect,
IChannels chans 
)
pure virtual

Implement this to execute your post effect. It runs in a worker thread.

Parameters
rectis the rectangle to be processed.
chansis the collection of channels to process.
Returns
true if successful, else false.