Rhino C++ API  8.6
Public Member Functions | Protected Member Functions | List of all members
IRhRdkPostEffects Class Referenceabstract

#include <IRhRdkPostEffects.h>

Public Member Functions

virtual IRhRdkPostEffectsBeginChange (RhRdkChangeContext cc) const =0
 
virtual bool EndChange (void)=0
 
virtual void * EVF (const wchar_t *, void *)=0
 
virtual void GetPostEffects (IRhRdkPostEffect::Types type, OUT ON_SimpleArray< IRhRdkPostEffect * > &a) const =0
 
virtual IRhRdkPostEffectPostEffectFromId (const UUID &uuidPEP) const =0
 

Protected Member Functions

virtual ~IRhRdkPostEffects ()
 

Detailed Description

This is the interface to a collection of post effects.

Constructor & Destructor Documentation

◆ ~IRhRdkPostEffects()

virtual IRhRdkPostEffects::~IRhRdkPostEffects ( )
inlineprotectedvirtual

Member Function Documentation

◆ BeginChange()

virtual IRhRdkPostEffects& IRhRdkPostEffects::BeginChange ( RhRdkChangeContext  cc) const
pure virtual

Call this method to get a non-const object upon which you can call non-const methods. Calls to this method are counted; you must call EndChange() once for every call to BeginChange(). Please do not use const_cast or any other means of circumventing this requirement.

◆ EndChange()

virtual bool IRhRdkPostEffects::EndChange ( void  )
pure virtual

◆ EVF()

virtual void* IRhRdkPostEffects::EVF ( const wchar_t *  ,
void *   
)
pure virtual

Emergency virtual function for future expansion.

◆ GetPostEffects()

virtual void IRhRdkPostEffects::GetPostEffects ( IRhRdkPostEffect::Types  type,
OUT ON_SimpleArray< IRhRdkPostEffect * > &  a 
) const
pure virtual

Get all the post effects.

Parameters
aaccepts the post effects.
Note
This method is const but should not be. You can get non-const post effects without calling Begin/EndChange(). If you do this, the system will not work properly, so please make sure you call Begin/EndChange() if you want to modify the post effects.

◆ PostEffectFromId()

virtual IRhRdkPostEffect* IRhRdkPostEffects::PostEffectFromId ( const UUID &  uuidPEP) const
pure virtual

Find a post effect plug-in from its id.