Rhino C++ API
8.13
|
#include <IRhRdkRenderChannels.h>
Public Types | |
enum | Modes : unsigned int { Modes::Automatic, Modes::Custom } |
Mode. More... | |
Public Member Functions | |
virtual | ~IRhRdkRenderChannels () |
virtual IRhRdkRenderChannels & | BeginChange (RhRdkChangeContext cc) const =0 |
virtual void | BeginNotifyBracket (void)=0 |
virtual void | CopyFrom (const IRhRdkRenderChannels &rch)=0 |
virtual bool | EndChange (void)=0 |
virtual void | EndNotifyBracket (void)=0 |
virtual void * | EVF (const wchar_t *, void *)=0 |
virtual void | GetCustomList (OUT ON_SimpleArray< UUID > &aChan) const =0 |
virtual Modes | Mode (void) const =0 |
virtual void | SetCustomList (const ON_SimpleArray< UUID > &aChan)=0 |
virtual void | SetMode (Modes m)=0 |
Static Public Member Functions | |
static IRhRdkRenderChannels * | New (void) |
This interface is deprecated and only kept for backward compatibility.
|
strong |
|
inlinevirtual |
|
pure virtual |
Call this method to get a non-const object upon which you can call non-const methods. Calls to this method are counted; you must call EndChange() once for every call to BeginChange(). Please do not use const_cast or any other means of circumventing this requirement.
|
pure virtual |
Call this before calling multiple 'Set' methods.
|
pure virtual |
Copy this object from another one.
|
pure virtual |
|
pure virtual |
Call this after calling multiple 'Set' methods.
|
pure virtual |
Emergency virtual function for future expansion.
|
pure virtual |
Get the list of channels to render when in 'custom' mode.
aChan | accepts the channel ids. |
|
pure virtual |
Get the mode.
|
static |
|
pure virtual |
Set the list of channels to render when in 'custom' mode.
aChan | contains the channel ids. |
|
pure virtual |
Set the mode.