Rhino C++ API  8.5
Public Member Functions | Static Public Member Functions | List of all members
IRhRdkSkylight Class Referenceabstract

#include <IRhRdkSkylight.h>

Public Member Functions

virtual ~IRhRdkSkylight ()
 
virtual IRhRdkSkylightBeginChange (RhRdkChangeContext cc) const =0
 
virtual void BeginNotifyBracket (void)=0
 
virtual void CopyFrom (const IRhRdkSkylight &sl)=0
 
virtual UUID CustomEnvironment (void) const =0
 
virtual bool CustomEnvironmentOn (void) const =0
 
bool Enabled (void) const
 
virtual bool EndChange (void)=0
 
virtual void EndNotifyBracket (void)=0
 
virtual void * EVF (const wchar_t *wszFunc, void *pvData)=0
 
virtual bool IsEqual (const IRhRdkSkylight &sl) const =0
 
virtual bool On (void) const =0
 
virtual void SetCustomEnvironment (const UUID &uuidInstance)=0
 
virtual void SetCustomEnvironmentOn (bool bOn)=0
 
void SetEnabled (bool b)
 
virtual void SetOn (bool bOn)=0
 
virtual void SetShadowIntensity (double dIntensity)=0
 
virtual double ShadowIntensity (void) const =0
 

Static Public Member Functions

static IRhRdkSkylightNew (void)
 

Detailed Description

This interface is deprecated and only kept for backward compatibility.

Constructor & Destructor Documentation

◆ ~IRhRdkSkylight()

virtual IRhRdkSkylight::~IRhRdkSkylight ( )
inlinevirtual

Member Function Documentation

◆ BeginChange()

virtual IRhRdkSkylight& IRhRdkSkylight::BeginChange ( RhRdkChangeContext  cc) const
pure virtual

Call this method to get a non-const object upon which you can call non-const methods. Calls to this method are counted; you must call EndChange() once for every call to BeginChange(). Please do not use const_cast or any other means of circumventing this requirement.

◆ BeginNotifyBracket()

virtual void IRhRdkSkylight::BeginNotifyBracket ( void  )
pure virtual

Call this before doing multiple 'Set' operations.

◆ CopyFrom()

virtual void IRhRdkSkylight::CopyFrom ( const IRhRdkSkylight sl)
pure virtual

Copies another skylight to this one.

◆ CustomEnvironment()

virtual UUID IRhRdkSkylight::CustomEnvironment ( void  ) const
pure virtual
Returns
The skylight custom environment instance id. If none has been set, returns ON_nil_uuid.
Note
If you are a rendering engine, please prefer CRhRdkDocument::CurrentEnvironment().Get(IRhRdkCurrentEnvironment::Usage::Skylighting, IRhRdkCurrentEnvironment::Purpose::Render); This includes all of the logic to check which environment should be used for which purpose, and how the environments should defer to each other when one is not available.

◆ CustomEnvironmentOn()

virtual bool IRhRdkSkylight::CustomEnvironmentOn ( void  ) const
pure virtual
Returns
true if the skylight custom environment is on, else false.

◆ Enabled()

bool IRhRdkSkylight::Enabled ( void  ) const
inline

◆ EndChange()

virtual bool IRhRdkSkylight::EndChange ( void  )
pure virtual

◆ EndNotifyBracket()

virtual void IRhRdkSkylight::EndNotifyBracket ( void  )
pure virtual

Call this after doing multiple 'Set' operations. If one of the operations modified the document skylight, the OnSkylightSettingsChanged event will be sent.

◆ EVF()

virtual void* IRhRdkSkylight::EVF ( const wchar_t *  wszFunc,
void *  pvData 
)
pure virtual

Emergency virtual function for future expansion.

◆ IsEqual()

virtual bool IRhRdkSkylight::IsEqual ( const IRhRdkSkylight sl) const
pure virtual
Returns
true if this skylight is equal to another one.

◆ New()

static IRhRdkSkylight* IRhRdkSkylight::New ( void  )
static

Create a new free-floating skylight object that can be used for storage purposes.

◆ On()

virtual bool IRhRdkSkylight::On ( void  ) const
pure virtual
Returns
true if the skylight is on, else false.

◆ SetCustomEnvironment()

virtual void IRhRdkSkylight::SetCustomEnvironment ( const UUID &  uuidInstance)
pure virtual

Set the skylight custom environment instance id.

Parameters
uuidInstanceis the instance id of the environment to use.

◆ SetCustomEnvironmentOn()

virtual void IRhRdkSkylight::SetCustomEnvironmentOn ( bool  bOn)
pure virtual

Set the skylight custom environment on or off.

◆ SetEnabled()

void IRhRdkSkylight::SetEnabled ( bool  b)
inline

◆ SetOn()

virtual void IRhRdkSkylight::SetOn ( bool  bOn)
pure virtual

Set the skylight on or off.

◆ SetShadowIntensity()

virtual void IRhRdkSkylight::SetShadowIntensity ( double  dIntensity)
pure virtual

Set the skylight shadow intensity. This is unused at present.

◆ ShadowIntensity()

virtual double IRhRdkSkylight::ShadowIntensity ( void  ) const
pure virtual
Returns
The skylight shadow intensity. This is unused at present.