Rhino C++ API  8.6
Public Member Functions | Protected Member Functions | List of all members
IRhRdkTaskUpdate Class Referenceabstract

#include <RhRdkTask.h>

Public Member Functions

virtual void DeleteThis (void)=0
 
virtual void * EVF (const wchar_t *, void *)=0
 
virtual bool IsChecked (void) const =0
 
virtual bool IsEnabled (void) const =0
 
virtual const IRhRdkTaskOriginOrigin (void) const =0
 
virtual void SetIsChecked (bool)=0
 
virtual void SetIsEnabled (bool)=0
 
virtual void SetRadio (bool)=0
 

Protected Member Functions

virtual ~IRhRdkTaskUpdate ()
 

Constructor & Destructor Documentation

◆ ~IRhRdkTaskUpdate()

virtual IRhRdkTaskUpdate::~IRhRdkTaskUpdate ( )
inlineprotectedvirtual

Member Function Documentation

◆ DeleteThis()

virtual void IRhRdkTaskUpdate::DeleteThis ( void  )
pure virtual

This method is implemented as

delete this;

◆ EVF()

virtual void* IRhRdkTaskUpdate::EVF ( const wchar_t *  ,
void *   
)
pure virtual

Emergency virtual function for future expansion.

◆ IsChecked()

virtual bool IRhRdkTaskUpdate::IsChecked ( void  ) const
pure virtual

Get the task UI's 'checked' state.

◆ IsEnabled()

virtual bool IRhRdkTaskUpdate::IsEnabled ( void  ) const
pure virtual

Get the task UI's 'enabled' state.

Note
The default enabled state is true unless an implementation sets it to false.

◆ Origin()

virtual const IRhRdkTaskOrigin& IRhRdkTaskUpdate::Origin ( void  ) const
pure virtual

Get the task origin. This depends on the UI the user clicked in to invoke the menu or other UI that displays tasks.

◆ SetIsChecked()

virtual void IRhRdkTaskUpdate::SetIsChecked ( bool  )
pure virtual

Set the task UI's 'checked' state. Useful for menu check items.

◆ SetIsEnabled()

virtual void IRhRdkTaskUpdate::SetIsEnabled ( bool  )
pure virtual

Set the task UI's 'enabled' state.

◆ SetRadio()

virtual void IRhRdkTaskUpdate::SetRadio ( bool  )
pure virtual

Set the task UI's 'radio' state. Useful for menu radio items.