Rhino C++ API  8.6
Public Member Functions | Protected Member Functions | List of all members
IRhRdkTextureEvaluator::IChildCallback Class Referenceabstract

#include <IRhRdkTextureEvaluator.h>

Public Member Functions

virtual void DeleteThis (void)=0
 
virtual void * EVF (const wchar_t *, void *)=0
 
virtual bool GetChildColor (int iIndex, void *pvData, const ON_3dPoint &uvw, const ON_3dVector &duvwdx, const ON_3dVector &duvwdy, CRhRdkColor &colOut) const =0
 
virtual int InitializeChild (const CRhRdkContent *pChild, void *pvData)=0
 
virtual UUID RenderEngineId (void) const =0
 

Protected Member Functions

virtual ~IChildCallback ()
 

Detailed Description

This class allows a plug-in developer to handle the color requests for the children of this texture evaluator. For example, if this is a texture evaluator for a blend texture, the developer will be given the opportunity to return the colors for each of the two blend textures instead of the standard method which would involve creating texture evaluators for those textures using pChild->NewTextureEvaluator. This system is intended to be used by developers of textures that do not support texture evaluation.

Constructor & Destructor Documentation

◆ ~IChildCallback()

virtual IRhRdkTextureEvaluator::IChildCallback::~IChildCallback ( )
inlineprotectedvirtual

Member Function Documentation

◆ DeleteThis()

virtual void IRhRdkTextureEvaluator::IChildCallback::DeleteThis ( void  )
pure virtual

You must implement this method as

delete this;

◆ EVF()

virtual void* IRhRdkTextureEvaluator::IChildCallback::EVF ( const wchar_t *  ,
void *   
)
pure virtual

Emergency virtual function for future expansion.

◆ GetChildColor()

virtual bool IRhRdkTextureEvaluator::IChildCallback::GetChildColor ( int  iIndex,
void *  pvData,
const ON_3dPoint uvw,
const ON_3dVector duvwdx,
const ON_3dVector duvwdy,
CRhRdkColor colOut 
) const
pure virtual

◆ InitializeChild()

virtual int IRhRdkTextureEvaluator::IChildCallback::InitializeChild ( const CRhRdkContent pChild,
void *  pvData 
)
pure virtual

◆ RenderEngineId()

virtual UUID IRhRdkTextureEvaluator::IChildCallback::RenderEngineId ( void  ) const
pure virtual