Rhino C++ API
8.13
|
#include <IRhRdkDithering.h>
Public Types | |
enum | Methods : unsigned int { Methods::None, Methods::BlackWhitePoint, Methods::Logarithmic } |
Public Member Functions | |
virtual bool | ApplyWhileRendering (void) const =0 |
virtual void * | EVF (const wchar_t *wszFunc, void *pvData)=0 |
virtual void | GetParams (OUT IRhRdk_XMLSection §ion) const =0 |
virtual IRhRdkToneMapping::Methods | Method (void) const =0 |
virtual void | SetApplyWhileRendering (bool b)=0 |
virtual void | SetMethod (IRhRdkToneMapping::Methods)=0 |
virtual void | SetParams (const IRhRdk_XMLSection §ion)=0 |
Protected Member Functions | |
virtual | ~IRhRdkToneMapping () |
This interface is deprecated and only kept for backward compatibility.
|
strong |
|
inlineprotectedvirtual |
|
pure virtual |
Get whether or not tone mapping will be applied during rendering.
|
pure virtual |
Emergency virtual function for future expansion.
|
pure virtual |
Get tone mapping params.
|
pure virtual |
Get tone mapping method.
|
pure virtual |
Set whether or not tone mapping will be applied during rendering.
|
pure virtual |
Set tone mapping method.
|
pure virtual |
Set tone mapping params.