Rhino C++ API
8.13
|
#include <IRhRdkToolbar.h>
Public Member Functions | |
virtual | ~IRhRdkToolbar () |
virtual bool | AddButton (const UUID &uuidAction)=0 |
virtual void | AddSeparator (void)=0 |
virtual void * | EVF (const wchar_t *, void *)=0 |
This interface facilitates possible future inclusion of a tool bar in the RDK content editor dialog. This feature is currently not implemented and is included only for future compatibility.
|
inlinevirtual |
|
pure virtual |
Add a button to the toolbar.
uuidAction | is the identifier of the action to associate with the button. |
|
pure virtual |
Add a separator to the toolbar.
|
pure virtual |
Emergency virtual function for future expansion.