#include <RhRdkDataSource.h>
|
virtual void | DeleteThis (void)=0 |
|
virtual void * | EVF (const wchar_t *wszFunc, void *pvData)=0 |
|
virtual void | SetDescription (const wchar_t *wsz)=0 |
|
This interface is returned by IRhRdkUndo::NewUndoRecord().
- See also
- IRhRdkUndo
-
uuidData_RdkUndo
◆ ~IRhRdkUndoRecord()
virtual IRhRdkUndoRecord::~IRhRdkUndoRecord |
( |
| ) |
|
|
inlineprotectedvirtual |
◆ DeleteThis()
virtual void IRhRdkUndoRecord::DeleteThis |
( |
void |
| ) |
|
|
pure virtual |
This method is implemented as
◆ EVF()
virtual void* IRhRdkUndoRecord::EVF |
( |
const wchar_t * |
wszFunc, |
|
|
void * |
pvData |
|
) |
| |
|
pure virtual |
Emergency virtual function for future expansion.
◆ SetDescription()
virtual void IRhRdkUndoRecord::SetDescription |
( |
const wchar_t * |
wsz | ) |
|
|
pure virtual |
Set the localized description of the undo record.