#include <rhinoSdkWidget.h>
|
virtual | ~IRhWidgetDrawCache () |
|
virtual void | AddArc (const ON_Arc &a, const UUID &uuidObject)=0 |
|
virtual void | AddArrow (const ON_3dPoint &pt1, const ON_3dPoint &pt2, const UUID &uuidObject)=0 |
|
virtual void | AddCircle (const ON_Circle &c, const UUID &uuidObject)=0 |
|
virtual void | AddClippingPlane (ON_3dPoint cornerA, ON_3dPoint cornerB, ON_3dPoint cornerC, ON_3dPoint cornerD, const UUID &uuidObject)=0 |
|
virtual void | AddDottedLine (const ON_3dPoint &pt1, const ON_3dPoint &pt2, const UUID &uuidObject)=0 |
|
virtual void | AddEllipse (const ON_Ellipse &e, const UUID &uuidObject)=0 |
|
virtual void | AddLine (const ON_3dPoint &pt1, const ON_3dPoint &pt2, const UUID &uuidObject)=0 |
|
virtual void | AddObject (CRhWidgetGeometryCustomObjectRef &ref, const UUID &uuidObject)=0 |
|
virtual CRhWidgetDrawAttr | DrawAttr (void) const =0 |
|
virtual COLORREF | SetColor (COLORREF col)=0 |
|
virtual CRhWidgetDrawAttr | SetDrawAttr (const CRhWidgetDrawAttr &da)=0 |
|
virtual void | SetInterestObject (const UUID &uuidIO)=0 |
|
virtual UINT | SetPattern (UINT p)=0 |
|
virtual bool | SetUseAxisColors (bool b)=0 |
|
virtual bool | SnapTo (const CRhinoSnapContext &sc, CRhinoSnapEvent &se, const ON_Xform &xformLocal) const =0 |
|
virtual bool | UseAxisColors (void) const =0 |
|
Description:
This is the interface through which clients can draw widget geometry. See CRhinoWidgetGeometry::AddToDrawCache()
◆ ~IRhWidgetDrawCache()
virtual IRhWidgetDrawCache::~IRhWidgetDrawCache |
( |
| ) |
|
|
inlinevirtual |
◆ AddArc()
virtual void IRhWidgetDrawCache::AddArc |
( |
const ON_Arc & |
a, |
|
|
const UUID & |
uuidObject |
|
) |
| |
|
pure virtual |
◆ AddArrow()
virtual void IRhWidgetDrawCache::AddArrow |
( |
const ON_3dPoint & |
pt1, |
|
|
const ON_3dPoint & |
pt2, |
|
|
const UUID & |
uuidObject |
|
) |
| |
|
pure virtual |
◆ AddCircle()
virtual void IRhWidgetDrawCache::AddCircle |
( |
const ON_Circle & |
c, |
|
|
const UUID & |
uuidObject |
|
) |
| |
|
pure virtual |
◆ AddClippingPlane()
◆ AddDottedLine()
virtual void IRhWidgetDrawCache::AddDottedLine |
( |
const ON_3dPoint & |
pt1, |
|
|
const ON_3dPoint & |
pt2, |
|
|
const UUID & |
uuidObject |
|
) |
| |
|
pure virtual |
◆ AddEllipse()
virtual void IRhWidgetDrawCache::AddEllipse |
( |
const ON_Ellipse & |
e, |
|
|
const UUID & |
uuidObject |
|
) |
| |
|
pure virtual |
◆ AddLine()
virtual void IRhWidgetDrawCache::AddLine |
( |
const ON_3dPoint & |
pt1, |
|
|
const ON_3dPoint & |
pt2, |
|
|
const UUID & |
uuidObject |
|
) |
| |
|
pure virtual |
◆ AddObject()
virtual void IRhWidgetDrawCache::AddObject |
( |
CRhWidgetGeometryCustomObjectRef & |
ref, |
|
|
const UUID & |
uuidObject |
|
) |
| |
|
pure virtual |
◆ DrawAttr()
◆ SetColor()
virtual COLORREF IRhWidgetDrawCache::SetColor |
( |
COLORREF |
col | ) |
|
|
pure virtual |
◆ SetDrawAttr()
◆ SetInterestObject()
virtual void IRhWidgetDrawCache::SetInterestObject |
( |
const UUID & |
uuidIO | ) |
|
|
pure virtual |
◆ SetPattern()
virtual UINT IRhWidgetDrawCache::SetPattern |
( |
UINT |
p | ) |
|
|
pure virtual |
◆ SetUseAxisColors()
virtual bool IRhWidgetDrawCache::SetUseAxisColors |
( |
bool |
b | ) |
|
|
pure virtual |
◆ SnapTo()
◆ UseAxisColors()
virtual bool IRhWidgetDrawCache::UseAxisColors |
( |
void |
| ) |
const |
|
pure virtual |