Rhino C++ API
8.13
|
Interface to preview and perform mesh extrusions. More...
#include <rhinoSdkMeshUtilities.h>
Public Types | |
enum | FaceDirectionMode : int { FaceDirectionMode::Keep = 0, FaceDirectionMode::OrientClosedFrontOut = 1 } |
Defines how mesh extruder decides orients faces More... | |
enum | ParameterMode : int { ParameterMode::CoverWalls = 0, ParameterMode::KeepAndStretch = 1 } |
Parameter mode for creating texture coordinates and surface parameters More... | |
Public Member Functions | |
virtual void | DeleteThis (void)=0 |
virtual void * | EVF (const wchar_t *, void *) |
virtual bool | ExtrudedMesh (ON_Mesh &meshOut)=0 |
virtual bool | ExtrudedMesh (ON_Mesh &meshOut, ON_SimpleArray< ON_COMPONENT_INDEX > &extrudedComponentsOut)=0 |
virtual FaceDirectionMode | FaceMode (void) const =0 |
virtual bool | KeepOriginalFaces (void) const =0 |
virtual void | PreviewLines (ON_SimpleArray< ON_Line > &linesOut)=0 |
virtual void | SetFaceMode (FaceDirectionMode mode)=0 |
virtual void | SetKeepOriginalFaces (bool bEnable)=0 |
virtual void | SetSurfaceParameterMode (ParameterMode mode)=0 |
virtual void | SetTextureCoordinateMode (ParameterMode mode)=0 |
virtual void | SetTransform (const ON_3dVector &translation)=0 |
virtual void | SetTransform (const ON_Xform &transform)=0 |
virtual void | SetUVN (bool bEnable)=0 |
virtual ParameterMode | SurfaceParameterMode (void) const =0 |
virtual ParameterMode | TextureCoordinateMode (void) const =0 |
virtual ON_Xform | Transform (void) const =0 |
virtual bool | UVN (void) const =0 |
Static Public Member Functions | |
static IRhinoMeshExtruder * | NewMeshExtruder (const ON_Mesh &inputMesh, const ON_SimpleArray< ON_COMPONENT_INDEX > &componentIndices) |
Protected Member Functions | |
IRhinoMeshExtruder () | |
IRhinoMeshExtruder (const IRhinoMeshExtruder &)=delete | |
virtual | ~IRhinoMeshExtruder () |
IRhinoMeshExtruder & | operator= (const IRhinoMeshExtruder &)=delete |
Interface to preview and perform mesh extrusions.
|
strong |
|
strong |
|
inlineprotected |
|
inlineprotectedvirtual |
|
protecteddelete |
|
pure virtual |
Description: Deletes this instance
|
inlinevirtual |
Description: Emergency virtual function
|
pure virtual |
Description: Applies extrude Return true if any faces or edges were extruded. Parameters: meshOut - [out] This mesh will be the result of applying extrude to the input mesh passed to NewMeshExtruder.
|
pure virtual |
Description: Applies extrude and gives list of components that should be selected in extruded mesh. Return true if any faces or edges were extruded. Parameters: meshOut - [out] This mesh will be the result of applying extrude to the input mesh passed to NewMeshExtruder. extrudedComponentsOut - [out] List of components that should be selected in extruded mesh.
|
pure virtual |
Description: Gets face direction mode
|
pure virtual |
Description: True if original faces are deleted and false if not
|
static |
Description: Returns a new instance of interface implementation. Caller must delete returned instance by calling DeleteThis(). Parameters: inputMesh - [in] Mesh to use as starting point componentIndices - [in] Mesh faces, edges and ngons to extrude
|
protecteddelete |
|
pure virtual |
Description: Creates a set of lines to preview extruded mesh. Parameters: linesOut - [out] Lines to preview extruded mesh
|
pure virtual |
Description: Sets face direction mode Parameters: mode - [in] mode to use
|
pure virtual |
Description: Sets whether to keep original faces. By default they will be deleted. Parameters: bEnable - [in] True to keep original faces and false to delete them
|
pure virtual |
Description: Sets parameter mode for surface parameters Parameters: mode - [in] mode to use
|
pure virtual |
Description: Sets parameter mode for texture coordinates Parameters: mode - [in] mode to use
|
pure virtual |
Description: Sets transform of extrusion by translation vector. Parameters: translation - [in] Translation vector
|
pure virtual |
Description: Sets transform of extrusion. Parameters: transform - [in] Transform to use
|
pure virtual |
Description: Sets whether or not to perform extrude in UVN basis Parameters: bEnable - [in] True to perform extrude in UVN basis, false to perform in world coordinate system
|
pure virtual |
Description: Gets parameter mode for surface parameters
|
pure virtual |
Description: Gets parameter mode for texture coordinates
|
pure virtual |
Description: Gets transform of extrusion.
|
pure virtual |
Description: Gets whether or not to perform extrude in UVN basis