Rhino C++ API  8.6
Public Member Functions | Protected Member Functions | List of all members
IRhinoPage Class Referenceabstract

#include <RhinoSdkPages.h>

Inheritance diagram for IRhinoPage:
IRhinoOptionsPage IRhinoPropertiesPanelPage

Public Member Functions

virtual ~IRhinoPage ()=default
 
virtual bool Activated (const class IRhinoPageHost *host, bool activated) const
 
virtual ON_2iSize DefaultSize () const
 
virtual const wchar_t * EnglishTitle () const =0
 
virtual void HostWindowCreated (const class IRhinoPageHost *host) const
 
virtual RHINO_WINDOW_IMAGE_HANDLE Image (ON_2iSize size)=0
 
virtual const wchar_t * LocalTitle () const
 
virtual ON_2iSize MinimumSize () const
 
virtual LPARAM PageProc (unsigned int message, WPARAM wParam, LPARAM lParam)
 
virtual void Release ()=0
 
virtual bool ShowHelp (const class IRhinoPageHost *host) const
 
virtual IRhinoWindowWindow ()=0
 

Protected Member Functions

 IRhinoPage ()=default
 
 IRhinoPage (const IRhinoPage &)=delete
 
IRhinoPageoperator= (const IRhinoPage &)=delete
 

Detailed Description

class IRhinoPage

Description: Generic page interface, requires minimum, common interface.

Constructor & Destructor Documentation

◆ ~IRhinoPage()

virtual IRhinoPage::~IRhinoPage ( )
virtualdefault

◆ IRhinoPage() [1/2]

IRhinoPage::IRhinoPage ( )
protecteddefault

Description: Default constructor.

◆ IRhinoPage() [2/2]

IRhinoPage::IRhinoPage ( const IRhinoPage )
protecteddelete

Description: Delete the default copy constructor

Member Function Documentation

◆ Activated()

virtual bool IRhinoPage::Activated ( const class IRhinoPageHost host,
bool  activated 
) const
virtual

Description: Called when the host window becomes the active page or when another page is about to be made the active page. Parameters: activated[in] If true then the page has become the active page otherwise; another page is about to be made the active page. Returns: The return value is only significant if activated is false, in that case returning false will prevent the page from being deactivated and returning true will allow it to be deactivated. Return false if there is an error on the page you want the user to correct before applying changes.

◆ DefaultSize()

virtual ON_2iSize IRhinoPage::DefaultSize ( ) const
virtual

Description: Called to get the default size of the page, used by the host to calculate the vertical scroll bar. If 0x0 is returned then the default window size is used when the page is initially created.

◆ EnglishTitle()

virtual const wchar_t* IRhinoPage::EnglishTitle ( ) const
pure virtual

Description: Called to get the English name for this page. Returns: The English name for this page.

◆ HostWindowCreated()

virtual void IRhinoPage::HostWindowCreated ( const class IRhinoPageHost host) const
virtual

Description: Called when the host window has been created

◆ Image()

virtual RHINO_WINDOW_IMAGE_HANDLE IRhinoPage::Image ( ON_2iSize  size)
pure virtual

Description: Called to get the icon used by the host to identify this page. Parameters: size[in] = Desired icon size. Returns: The icon used by the host to identify this page.

◆ LocalTitle()

virtual const wchar_t* IRhinoPage::LocalTitle ( ) const
virtual

Description: Called to get the localized name for this page using the current Rhino language Id. Returns: The localized name for this page using the current Rhino language Id.

◆ MinimumSize()

virtual ON_2iSize IRhinoPage::MinimumSize ( ) const
virtual

Description: Called to get the minimum size of the page to be used by the host. Returns: The minimum size of the page to be used by the host.

◆ operator=()

IRhinoPage& IRhinoPage::operator= ( const IRhinoPage )
protecteddelete

Description: Delete the default operator=

◆ PageProc()

virtual LPARAM IRhinoPage::PageProc ( unsigned int  message,
WPARAM  wParam,
LPARAM  lParam 
)
virtual

Description: Reserved for future use to extend class without breaking the SDK

◆ Release()

virtual void IRhinoPage::Release ( )
pure virtual

Description: Called when the object is no longer referenced by the framework, decrement your reference counter and delete this object when the counter is 0.

◆ ShowHelp()

virtual bool IRhinoPage::ShowHelp ( const class IRhinoPageHost host) const
virtual

Description: Called by the host to display help for the page Returns: If true it returned the host will assume the page handled the help request otherwise; the host will display the default help.

◆ Window()

virtual IRhinoWindow* IRhinoPage::Window ( )
pure virtual

Description: Window to display in this page.