Rhino C++ API  8.6
Public Member Functions | Protected Member Functions | List of all members
IRhinoUiDataSourceEventWatcher Class Referenceabstract

#include <RhRdkDataSource.h>

Inheritance diagram for IRhinoUiDataSourceEventWatcher:
IRhinoUiDataSourceHost IRhinoUiController

Public Member Functions

virtual void Delete (void)=0
 
virtual void * EVF (const wchar_t *wszFunc, void *pvData)=0
 
virtual void OnEvent (const UUID &uuidData, const IRhinoUiEventInfo *pInfo)=0
 

Protected Member Functions

virtual ~IRhinoUiDataSourceEventWatcher ()
 

Detailed Description

Any object that has access to a data source can register itself to receive events from that data source by implementing this interface and calling IRhinoUiDataSource::RegisterEventWatcher()

Constructor & Destructor Documentation

◆ ~IRhinoUiDataSourceEventWatcher()

virtual IRhinoUiDataSourceEventWatcher::~IRhinoUiDataSourceEventWatcher ( )
inlineprotectedvirtual

Member Function Documentation

◆ Delete()

virtual void IRhinoUiDataSourceEventWatcher::Delete ( void  )
pure virtual

Implement this method to unregister and delete the event watcher.

◆ EVF()

virtual void* IRhinoUiDataSourceEventWatcher::EVF ( const wchar_t *  wszFunc,
void *  pvData 
)
pure virtual

Emergency virtual function for future expansion. Vanilla (non-host) data source event watchers must unregister by handling EVF("OnDeleteDataSource") wszFunc = "OnDeleteDataSource", pvData = IRhinoUiDataSource*

◆ OnEvent()

virtual void IRhinoUiDataSourceEventWatcher::OnEvent ( const UUID &  uuidData,
const IRhinoUiEventInfo pInfo 
)
pure virtual

Currently implemented by EVF. It should supplement Delete() which should only delete it. Sometimes an event watcher needs to be unregistered without being deleted. Implement this method to handle an event when the data of a certain type changes. Your handler will typically transfer data of that type to elements of your user interface.

Parameters
uuidDatais the identifier of the data.
pInfois a pointer to an object that contains more information about the event.
See also
IRhinoUiDataSource::RegisterEventWatcher()