Rhino C++ API
8.13
|
#include <opennurbs_plus_mesh_intersection.h>
Public Member Functions | |
ON_XMeshEdge (ON_XMeshVertex *pV0, ON_XMeshVertex *pV1) | |
~ON_XMeshEdge () | |
bool | ClosestPointToLine (const ON_3dPoint &P, double *t) const |
void | CreateComponentString (ON_wString &S) const override |
void | Edges (ON_SimpleArray< const ON_XMeshEdge * > &E) const override |
void | Edges (ON_SimpleArray< ON_XMeshEdge * > &E) override |
const ON_3dPoint & | EndPoint () const |
No checking for valid vertex. More... | |
ON_XMeshVertex * | EndVertex () |
const ON_XMeshVertex * | EndVertex () const |
ON_XMeshFace * | Face (int fid) |
const ON_XMeshFace * | Face (int fid) const |
int | FaceCount () const |
void | Faces (ON_SimpleArray< const ON_XMeshFace * > &F) const override |
Appends to array. More... | |
void | Faces (ON_SimpleArray< ON_XMeshFace * > &F) override |
Appends to array. More... | |
bool | IsDegenerate () const |
bool | IsValid () const override |
ON_3dPoint | MidPoint () const |
No checking for valid vertex. More... | |
ON_3dPoint | PointAt (double t) const |
const ON_3dPoint & | StartPoint () const |
No checking for valid vertex. More... | |
ON_XMeshVertex * | StartVertex () |
const ON_XMeshVertex * | StartVertex () const |
void | Vertices (ON_SimpleArray< const ON_XMeshVertex * > &V) const override |
void | Vertices (ON_SimpleArray< ON_XMeshVertex * > &V) override |
Whatever it is, what are the components that involve it? More... | |
Public Member Functions inherited from ON_XMeshComponent | |
virtual | ~ON_XMeshComponent () |
bool | AddEvent (ON_XMeshEvent *pX) |
ON_XMeshEdge * | Edge () |
const ON_XMeshEdge * | Edge () const |
ON_XMeshEvent * | Event (int xid) |
const ON_XMeshEvent * | Event (int xid) const |
int | EventCount () const |
Look through the event list. More... | |
ON_XMeshFace * | Face () |
const ON_XMeshFace * | Face () const |
const ON_XMeshEvent * | FindEvent (const ON_XMeshComponent *pC) const |
ON_XMeshEvent * | FindEvent (ON_XMeshComponent *pC) |
bool | HasEvent (const ON_XMeshComponent *pC) const |
Does m_X have a member with component? More... | |
bool | IsEdge () const |
bool | IsFace () const |
bool | IsVertex () const |
What is this thing? More... | |
void | RemoveEvent (ON_XMeshEvent *pX) |
ON_XMeshVertex * | Vertex () |
Cast. More... | |
const ON_XMeshVertex * | Vertex () const |
Friends | |
class | ON_XMesh |
class | ON_XMeshEdgeIterator |
class | ON_XMeshEdgePool |
class | ON_XMeshIntersector |
Additional Inherited Members | |
Protected Member Functions inherited from ON_XMeshComponent | |
ON_XMeshComponent () | |
ON_XMeshComponent (const ON_XMeshComponent &C) | |
Not implemented. More... | |
ON_XMeshComponent & | operator= (const ON_XMeshComponent &src) |
Not implemented. More... | |
Protected Attributes inherited from ON_XMeshComponent | |
bool | m_bIsValid |
const ON_XMesh * | m_pM |
used by fixed pool stuff More... | |
eXMeshPoolStatus | m_status |
ON_XMeshEventList * | m_X |
events not managed here More... | |
ON_XMeshEdge::ON_XMeshEdge | ( | ON_XMeshVertex * | pV0, |
ON_XMeshVertex * | pV1 | ||
) |
ON_XMeshEdge::~ON_XMeshEdge | ( | ) |
bool ON_XMeshEdge::ClosestPointToLine | ( | const ON_3dPoint & | P, |
double * | t | ||
) | const |
Finds parameter on the infinite line. Lexorders points to guarantee answer independent of line direction.
|
overridevirtual |
Reimplemented from ON_XMeshComponent.
|
overridevirtual |
Implements ON_XMeshComponent.
|
overridevirtual |
Implements ON_XMeshComponent.
const ON_3dPoint& ON_XMeshEdge::EndPoint | ( | ) | const |
No checking for valid vertex.
ON_XMeshVertex* ON_XMeshEdge::EndVertex | ( | ) |
const ON_XMeshVertex* ON_XMeshEdge::EndVertex | ( | ) | const |
ON_XMeshFace* ON_XMeshEdge::Face | ( | int | fid | ) |
const ON_XMeshFace* ON_XMeshEdge::Face | ( | int | fid | ) | const |
int ON_XMeshEdge::FaceCount | ( | ) | const |
|
overridevirtual |
Appends to array.
Implements ON_XMeshComponent.
|
overridevirtual |
Appends to array.
Implements ON_XMeshComponent.
bool ON_XMeshEdge::IsDegenerate | ( | ) | const |
|
overridevirtual |
Reimplemented from ON_XMeshComponent.
ON_3dPoint ON_XMeshEdge::MidPoint | ( | ) | const |
No checking for valid vertex.
ON_3dPoint ON_XMeshEdge::PointAt | ( | double | t | ) | const |
const ON_3dPoint& ON_XMeshEdge::StartPoint | ( | ) | const |
No checking for valid vertex.
ON_XMeshVertex* ON_XMeshEdge::StartVertex | ( | ) |
const ON_XMeshVertex* ON_XMeshEdge::StartVertex | ( | ) | const |
|
overridevirtual |
Implements ON_XMeshComponent.
|
overridevirtual |
Whatever it is, what are the components that involve it?
Implements ON_XMeshComponent.
|
friend |
|
friend |
|
friend |
|
friend |