#include <opennurbs_plus_mesh_intersection.h>
◆ ON_XMeshEdgeIterator() [1/3]
ON_XMeshEdgeIterator::ON_XMeshEdgeIterator |
( |
bool |
bMultiThread = false | ) |
|
◆ ON_XMeshEdgeIterator() [2/3]
ON_XMeshEdgeIterator::ON_XMeshEdgeIterator |
( |
const ON_XMeshEdgePool & |
Pool, |
|
|
bool |
bCheckX, |
|
|
ON_XMesh * |
pM, |
|
|
bool |
bMultiThread = false |
|
) |
| |
◆ ON_XMeshEdgeIterator() [3/3]
◆ ~ON_XMeshEdgeIterator()
ON_XMeshEdgeIterator::~ON_XMeshEdgeIterator |
( |
| ) |
|
◆ Count()
int ON_XMeshEdgeIterator::Count |
( |
| ) |
const |
Active count of the pool. If m_pM == 0 or m_bCheckX is false, this may be more
◆ Create()
void ON_XMeshEdgeIterator::Create |
( |
const ON_XMeshEdgePool & |
Pool, |
|
|
bool |
bCheckX, |
|
|
ON_XMesh * |
pM, |
|
|
bool |
bMultiThread = false |
|
) |
| |
◆ Current()
than the number of edges from this mesh that are active, but it does give a bound on the iteration.
◆ First()
◆ Next()
◆ operator=()
◆ Reset()
void ON_XMeshEdgeIterator::Reset |
( |
| ) |
|
To be used on the same pool with same mesh.