Rhino C++ API
8.13
|
#include <opennurbs_plus_mesh_intersection.h>
Public Member Functions | |
ON_XMeshEdgePool (bool bMultiThread=false) | |
~ON_XMeshEdgePool () | |
size_t | ActiveCount () const |
ON_XMeshEdge * | NewEdge (ON_XMeshVertex *pV0, ON_XMeshVertex *pV1, const ON_XMesh *pM) |
void | ReturnAll () |
bool | ReturnEdge (ON_XMeshEdge *&pE) |
pE comes back 0. False if status is not active More... | |
Friends | |
class | ON_XMeshEdgeIterator |
ON_XMeshEdgePool::ON_XMeshEdgePool | ( | bool | bMultiThread = false | ) |
ON_XMeshEdgePool::~ON_XMeshEdgePool | ( | ) |
size_t ON_XMeshEdgePool::ActiveCount | ( | ) | const |
ON_XMeshEdge* ON_XMeshEdgePool::NewEdge | ( | ON_XMeshVertex * | pV0, |
ON_XMeshVertex * | pV1, | ||
const ON_XMesh * | pM | ||
) |
void ON_XMeshEdgePool::ReturnAll | ( | ) |
bool ON_XMeshEdgePool::ReturnEdge | ( | ON_XMeshEdge *& | pE | ) |
pE comes back 0. False if status is not active
|
friend |