Rhino C++ API  8.5
Public Member Functions | Public Attributes | List of all members
RhDisplacement Class Reference

Represents surface displacement on an object. More...

#include <rhinoSdkMeshUtilities.h>

Public Member Functions

 RhDisplacement (const CRhRdkTexture *pRdkTexture, double dBlack, double dWhite, const ON_TextureMapping &textureMapping, const ON_Xform &mappingTransform, const ON_Xform &instanceTransform)
 
virtual ~RhDisplacement ()
 

Public Attributes

RhDisplacementImpl * m_pImpl
 

Detailed Description

Represents surface displacement on an object.

Constructor & Destructor Documentation

◆ RhDisplacement()

RhDisplacement::RhDisplacement ( const CRhRdkTexture pRdkTexture,
double  dBlack,
double  dWhite,
const ON_TextureMapping textureMapping,
const ON_Xform mappingTransform,
const ON_Xform instanceTransform 
)

Description: The constructor. Parameters: pRdkTexture - [in] The texture used as displacement dBlack - [in] Value considered lowest point of the displacement texture. dWhite - [in] Value considered highest point of the displacement texture. textureMapping - [in] The texture mapping of the mesh. mappingTransform - [in] Texture mapping transform. instanceTransform - [in] Instance transformation of the mesh.

◆ ~RhDisplacement()

virtual RhDisplacement::~RhDisplacement ( )
virtual

Member Data Documentation

◆ m_pImpl

RhDisplacementImpl* RhDisplacement::m_pImpl