Rhino C++ API  8.6
Public Member Functions | Public Attributes | List of all members
RhDisplacementArgs Class Reference

A class containing all displacement options. More...

#include <rhinoSdkMeshUtilities.h>

Public Member Functions

 RhDisplacementArgs ()
 The constructor sets the default option values. More...
 
bool operator!= (const RhDisplacementArgs &other) const
 
bool operator== (const RhDisplacementArgs &other) const
 

Public Attributes

double m_dAbsoluteTolerance
 Absolute tolerance used for sweep resolution when calculation formula needs it. More...
 
double m_dBlack
 The amount of displacement for the black color in the texture. More...
 
double m_dPostWeldAngle
 
double m_dRefineSensitivity
 
double m_dSweepPitch
 
double m_dWhite
 The amount of displacement for the white color in the texture. More...
 
int m_iChannelNumber
 Mapping channel number for the displacement mapping. More...
 
int m_iFaceLimit
 
int m_iFairingAmount
 Straightens rough feature edges. The value specifies the number of passes. More...
 
int m_iRefineStepCount
 Specifies the number of refinement passes. More...
 
int m_meshMemoryLimit
 Specifies in megabytes how much memory can be allocated for use by the displacement mesh. More...
 
RhDisplacementSweepResolutionFormula m_sweepResolutionFormula
 Specifies which formula is used to calculate sweep resolution from sweep pitch. More...
 

Detailed Description

A class containing all displacement options.

Constructor & Destructor Documentation

◆ RhDisplacementArgs()

RhDisplacementArgs::RhDisplacementArgs ( )

The constructor sets the default option values.

Member Function Documentation

◆ operator!=()

bool RhDisplacementArgs::operator!= ( const RhDisplacementArgs other) const

◆ operator==()

bool RhDisplacementArgs::operator== ( const RhDisplacementArgs other) const

Member Data Documentation

◆ m_dAbsoluteTolerance

double RhDisplacementArgs::m_dAbsoluteTolerance

Absolute tolerance used for sweep resolution when calculation formula needs it.

◆ m_dBlack

double RhDisplacementArgs::m_dBlack

The amount of displacement for the black color in the texture.

◆ m_dPostWeldAngle

double RhDisplacementArgs::m_dPostWeldAngle

Specifies the maximum angle between face normals of adjacent faces that will get welded together.

◆ m_dRefineSensitivity

double RhDisplacementArgs::m_dRefineSensitivity

Specifies how sensitive the divider for contrasts is on the displacement texture. Specify 1 to split all mesh edges on each refine step. Specify 0.99 to make even slight contrasts on the displacement texture cause edges to be split. Specifying 0.01 only splits edges where heavy contrast exists.

◆ m_dSweepPitch

double RhDisplacementArgs::m_dSweepPitch

Specifies how densely the object is initially subdivided. The lower the value, the higher the resolution of the displaced mesh.

◆ m_dWhite

double RhDisplacementArgs::m_dWhite

The amount of displacement for the white color in the texture.

◆ m_iChannelNumber

int RhDisplacementArgs::m_iChannelNumber

Mapping channel number for the displacement mapping.

◆ m_iFaceLimit

int RhDisplacementArgs::m_iFaceLimit

Runs a mesh reduction as a post process to simplify the result of displacement. to meet the specified number of faces.

◆ m_iFairingAmount

int RhDisplacementArgs::m_iFairingAmount

Straightens rough feature edges. The value specifies the number of passes.

◆ m_iRefineStepCount

int RhDisplacementArgs::m_iRefineStepCount

Specifies the number of refinement passes.

◆ m_meshMemoryLimit

int RhDisplacementArgs::m_meshMemoryLimit

Specifies in megabytes how much memory can be allocated for use by the displacement mesh.

◆ m_sweepResolutionFormula

RhDisplacementSweepResolutionFormula RhDisplacementArgs::m_sweepResolutionFormula

Specifies which formula is used to calculate sweep resolution from sweep pitch.