Rhino C++ API  8.5
Public Member Functions | Public Attributes | List of all members
RhMeshPipeArgs Class Reference

#include <rhinoSdkMeshUtilities.h>

Public Member Functions

 RhMeshPipeArgs ()
 The constructor sets the default arguments. More...
 
 RhMeshPipeArgs (const RhMeshPipeArgs &)
 
 ~RhMeshPipeArgs ()
 
unsigned int DocumentSerialNumber () const
 
const ON_LinetypeGetLinetype () const
 
RhMeshPipeArgsoperator= (const RhMeshPipeArgs &)
 
void SetDocument (unsigned int serialNumber)
 
void SetLinetype (const ON_Linetype *linetype)
 

Public Attributes

ON_SimpleArray< ON_Intervalm_aVisibleIntervals
 
bool m_bFaceted
 Specifies whether the pipe is faceted or not. More...
 
RhPipeCapType m_capType
 The type of cap to be created at the ends of the pipe. More...
 
double m_dRadius
 The radius of the pipe (minimum value 0.0001). More...
 
int m_iAccuracy
 The accuracy of the pipe. More...
 
int m_iSegments
 The number of segments in the pipe (minimum value 2). More...
 

Detailed Description

Description: Contains the arguments to the RhinoMeshPipeFromCurve function.

Constructor & Destructor Documentation

◆ RhMeshPipeArgs() [1/2]

RhMeshPipeArgs::RhMeshPipeArgs ( )

The constructor sets the default arguments.

◆ ~RhMeshPipeArgs()

RhMeshPipeArgs::~RhMeshPipeArgs ( )

◆ RhMeshPipeArgs() [2/2]

RhMeshPipeArgs::RhMeshPipeArgs ( const RhMeshPipeArgs )

Member Function Documentation

◆ DocumentSerialNumber()

unsigned int RhMeshPipeArgs::DocumentSerialNumber ( ) const

◆ GetLinetype()

const ON_Linetype* RhMeshPipeArgs::GetLinetype ( ) const

◆ operator=()

RhMeshPipeArgs& RhMeshPipeArgs::operator= ( const RhMeshPipeArgs )

◆ SetDocument()

void RhMeshPipeArgs::SetDocument ( unsigned int  serialNumber)

◆ SetLinetype()

void RhMeshPipeArgs::SetLinetype ( const ON_Linetype linetype)

Member Data Documentation

◆ m_aVisibleIntervals

ON_SimpleArray<ON_Interval> RhMeshPipeArgs::m_aVisibleIntervals

An array of intervals specifying which parts of the curve should be piped. Leave empty to pipe the whole curve.

◆ m_bFaceted

bool RhMeshPipeArgs::m_bFaceted

Specifies whether the pipe is faceted or not.

◆ m_capType

RhPipeCapType RhMeshPipeArgs::m_capType

The type of cap to be created at the ends of the pipe.

◆ m_dRadius

double RhMeshPipeArgs::m_dRadius

The radius of the pipe (minimum value 0.0001).

◆ m_iAccuracy

int RhMeshPipeArgs::m_iAccuracy

The accuracy of the pipe.

◆ m_iSegments

int RhMeshPipeArgs::m_iSegments

The number of segments in the pipe (minimum value 2).