Rhino C++ API  8.6
Public Member Functions | Public Attributes | List of all members
RhShutLiningCurveArgs Class Reference

Shut-lining curve arguments. More...

#include <rhinoSdkMeshUtilities.h>

Public Member Functions

 RhShutLiningCurveArgs ()
 The constructor sets the default arguments. More...
 

Public Attributes

ON_SimpleArray< ON_Intervalm_aCurveIntervals
 
bool m_bEnabled
 Specifies whether this curve should be shutlined. More...
 
bool m_bIsBump
 Specifies whether the shutline is coming out of the mesh. More...
 
bool m_bPull
 Specifies whether the curve should be pulled to the mesh. More...
 
const ON_Curvem_curve
 The curve used as a shutline. More...
 
double m_dRadius
 The radius of the shutline. More...
 
int m_iProfile
 The profile of the shutline. More...
 

Detailed Description

Shut-lining curve arguments.

Constructor & Destructor Documentation

◆ RhShutLiningCurveArgs()

RhShutLiningCurveArgs::RhShutLiningCurveArgs ( )

The constructor sets the default arguments.

Member Data Documentation

◆ m_aCurveIntervals

ON_SimpleArray<ON_Interval> RhShutLiningCurveArgs::m_aCurveIntervals

An array of intervals specifying which parts of the curve should be shutlined. Leave empty to pipe the whole curve.

◆ m_bEnabled

bool RhShutLiningCurveArgs::m_bEnabled

Specifies whether this curve should be shutlined.

◆ m_bIsBump

bool RhShutLiningCurveArgs::m_bIsBump

Specifies whether the shutline is coming out of the mesh.

◆ m_bPull

bool RhShutLiningCurveArgs::m_bPull

Specifies whether the curve should be pulled to the mesh.

◆ m_curve

const ON_Curve* RhShutLiningCurveArgs::m_curve

The curve used as a shutline.

◆ m_dRadius

double RhShutLiningCurveArgs::m_dRadius

The radius of the shutline.

◆ m_iProfile

int RhShutLiningCurveArgs::m_iProfile

The profile of the shutline.